Introduction

Database Documentation Summary

Database ptms

Number of Tables: 35 [ View Tables ]
Number of Views: 1 [ View Views ]
Number of Stored Procedures: 0
Number of Functions: 0
Number of Triggers: 0
Number of Indexes: 53 [ View Indexes ]
Number of Full-Text Catalogs: 0

Documentation was created by the SQL Documentation Tool on Friday, July 17, 2009 at 08:54, based on an examination of the database(s) performed on Friday, July 17, 2009 at 08:49.


Database ptms

Tables

Agencies
AgencyRateMappings
Clients
CustomReports
Destinations
Disabilities
Drivers
GISParameters
MiscellaneousCodes
MiscellaneousCodesValues
NewPas
NYCmn
NYParates
NYPriorApprovals
PaSharedRideCodes
ProcedureMatching
Providers
ReportOptions
RevenueCodes
Schedule
ScheduledTripSuspensions
SchedulingCapacityPerHour
ServiceRequests
States
SysProcLog
SystemParameters
Tripcodes
TripDistances
TripTransactions
Users
ValidServiceAuthorizations
Vehicles
VehicleServiceSummary
ZipCodes
Zones

Views

TripData

Stored Procedures

No stored procedures were found.

Functions

No functions were found.

Triggers

No triggers were found.

Indexes

PK_Agencies
U_Agency
PK_AgencyRateMappings
U_AgencyFundingPurposeTripcode
PK_Clients
PK_CustomReports
U_Report
PK_Destinations
U_Destination
PK_Disabilities
U_Disability
PK_Drivers
U_Driver
PK_GISParameters
PK_MiscellaneousCodes
PK__MiscellaneousCod__2C3393D0
PK_NYCmn
PK_NYParates
U_Tripcode
PK_NYPriorApprovals
U_MedidConfirmno
PK_PaSharedRideCodes
U_AgencyFundingPurposeTripcode
PK__ProcedureMatchin__756D6ECB
PK_Providers
U_Provider
PK__ReportOptions__33D4B598
PK_RevenueCodes
U_CodetypeCode
PK_Schedule
PK_ScheduledTripSuspensions
U_ClientIDScheduleRecordNumber
PK_SchedulingCapacityPerHour
U_ScheduleHour
PK_ServiceRequests
PK__States__2E1BDC42
PK__SysProcLog__31EC6D26
PK_SystemParameters
PK_Tripcodes
U_Tripcode
PK_TripDistances
PK_TripTransactions
U_TransactionNumberTripdate
PK_Users
U_UserNumber
PK_ValidServiceAuthorizations
U_AgencyFundingPurposeTripcode
PK_Vehicles
U_Vehicle
PK_VehicleServiceSummary
PK__ZipCodes__300424B4
PK_Zones
U_Zone

Full-Text Catalogs

No full-text catalogs were found.


Tables in Database ptms

Agencies
AgencyRateMappings
Clients
CustomReports
Destinations
Disabilities
Drivers
GISParameters
MiscellaneousCodes
MiscellaneousCodesValues
NewPas
NYCmn
NYParates
NYPriorApprovals
PaSharedRideCodes
ProcedureMatching
Providers
ReportOptions
RevenueCodes
Schedule
ScheduledTripSuspensions
SchedulingCapacityPerHour
ServiceRequests
States
SysProcLog
SystemParameters
Tripcodes
TripDistances
TripTransactions
Users
ValidServiceAuthorizations
Vehicles
VehicleServiceSummary
ZipCodes
Zones


Table ptms..Agencies

 | Column Name | Type | Length | Nullable | Description | Relationships
 | RateCategory | varchar | 1 | Yes |  |
 | OtherCategory | varchar | 1 | Yes |  |
 | SenderID | varchar | 15 | Yes |  |
 | ReceiverID | varchar | 15 | Yes |  |
 | ExcludeFas | bit |  | Yes |  |
 | AccountBalance | money |  | Yes |  |
 | LastUpdate | datetime |  | Yes |  |
 | MedicaidProviderID | varchar | 20 | Yes |  |
 | Timestamp | datetime |  | Yes |  |
Identity | ID | int identity |  | No |  |
 | Agency | varchar | 3 | Yes |  |
 | Description | varchar | 30 | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | Address1 | varchar | 30 | Yes |  |
 | Address2 | varchar | 30 | Yes |  |
 | City | varchar | 20 | Yes |  |
 | State | varchar | 2 | Yes |  |
 | Zipcode | varchar | 5 | Yes |  |
 | Phone1 | varchar | 13 | Yes |  |
 | Phone2 | varchar | 13 | Yes |  |
 | Extension1 | varchar | 4 | Yes |  |
 | Extension2 | varchar | 4 | Yes |  |
 | Note1 | varchar | 60 | Yes |  |
 | Note2 | varchar | 60 | Yes |  |
 | Note3 | varchar | 60 | Yes |  |
 | Note4 | varchar | 60 | Yes |  |
 | Note5 | varchar | 60 | Yes |  |
 | Postcode | varchar | 8 | Yes |  |
 | FaxNo | varchar | 13 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Agencies | clustered, unique, primary key located on PRIMARY | ID
U_Agency | nonclustered, unique located on PRIMARY | Agency


Table ptms..AgencyRateMappings

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Agency | varchar | 3 | Yes |  |
 | Funding | varchar | 3 | Yes |  |
 | Purpose | varchar | 3 | Yes |  |
 | Tripcode | varchar | 3 | Yes |  |
 | MileRate | money |  | Yes |  |
 | FlatRate | money |  | Yes |  |
 | PasgHourRate | money |  | Yes |  |
 | Formula | varchar | 1 | Yes |  |
 | Formdesc | varchar | 25 | Yes |  |
 | Threshold | numeric |  | Yes |  |
 | Surcharge | money |  | Yes |  |
 | Deductfare | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_AgencyRateMappings | clustered, unique, primary key located on PRIMARY | ID
U_AgencyFundingPurposeTripcode | nonclustered, unique located on PRIMARY | Agency, Funding, Purpose, Tripcode


Table ptms..Clients

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | ClientID | varchar | 10 | Yes |  |
 | IntakeDate | datetime |  | Yes |  |
 | LastUpDate | datetime |  | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | MI | varchar | 1 | Yes |  |
 | ADDRESS1 | varchar | 50 | Yes |  |
 | ADDRESS2 | varchar | 50 | Yes |  |
 | PHONE | varchar | 13 | Yes |  |
 | CITY | varchar | 20 | Yes |  |
 | STATE | varchar | 2 | Yes |  |
 | ZIPCODE | varchar | 5 | Yes |  |
 | A1 | varchar | 3 | Yes |  |
 | F1 | varchar | 3 | Yes |  |
 | P1 | varchar | 3 | Yes |  |
 | EXPDATE1 | datetime |  | Yes |  |
 | MEDID | varchar | 16 | Yes |  |
 | A2 | varchar | 3 | Yes |  |
 | F2 | varchar | 3 | Yes |  |
 | P2 | varchar | 3 | Yes |  |
 | EXPDATE2 | datetime |  | Yes |  |
 | SSN | varchar | 11 | Yes |  |
 | A3 | varchar | 3 | Yes |  |
 | F3 | varchar | 3 | Yes |  |
 | P3 | varchar | 3 | Yes |  |
 | EXPDATE3 | datetime |  | Yes |  |
 | olddob | varchar | 8 | Yes |  |
 | jdob | numeric |  | Yes |  |
 | A4 | varchar | 3 | Yes |  |
 | F4 | varchar | 3 | Yes |  |
 | P4 | varchar | 3 | Yes |  |
 | EXPDATE4 | datetime |  | Yes |  |
 | SPECIAL | varchar | 3 | Yes |  |
 | DRVINSTR | varchar | 255 | Yes |  |
 | SEX | varchar | 1 | Yes |  |
 | A5 | varchar | 3 | Yes |  |
 | F5 | varchar | 3 | Yes |  |
 | P5 | varchar | 3 | Yes |  |
 | EXPDATE5 | datetime |  | Yes |  |
 | SPECIALDC | varchar | 10 | Yes |  |
 | GISX | numeric |  | Yes |  |
 | PICKUPPL | varchar | 50 | Yes |  |
 | PICKUPA1 | varchar | 50 | Yes |  |
 | PICKUPA2 | varchar | 50 | Yes |  |
 | MASTER | varchar | 1 | Yes |  |
 | ZONCODE | varchar | 6 | Yes |  |
 | ZONNAME | varchar | 25 | Yes |  |
 | ACCTBAL | money |  | Yes |  |
 | BTNAME | varchar | 30 | Yes |  |
 | BTADD1 | varchar | 50 | Yes |  |
 | BTADD2 | varchar | 50 | Yes |  |
 | BTCITY | varchar | 25 | Yes |  |
 | BTSTATE | varchar | 2 | Yes |  |
 | BTZIPCODE | varchar | 5 | Yes |  |
 | BTPHONE | varchar | 13 | Yes |  |
 | RACE | varchar | 1 | Yes |  |
 | MARITAL | varchar | 1 | Yes |  |
 | INCOME | varchar | 1 | Yes |  |
 | INCSOURCE | varchar | 3 | Yes |  |
 | NOSCUR | numeric |  | Yes |  |
 | NOSTD | numeric |  | Yes |  |
 | CANCUR | numeric |  | Yes |  |
 | CANTD | numeric |  | Yes |  |
 | RTPCUR | numeric |  | Yes |  |
 | RTPTD | numeric |  | Yes |  |
 | TTPCUR | numeric |  | Yes |  |
 | TTPTD | numeric |  | Yes |  |
 | CASEMNGR | varchar | 100 | Yes |  |
 | EMCONTACT | varchar | 100 | Yes |  |
 | EMPHONE | varchar | 13 | Yes |  |
 | TRIPCODE1 | varchar | 3 | Yes |  |
 | TRIPCODE2 | varchar | 3 | Yes |  |
 | TRIPCODE3 | varchar | 3 | Yes |  |
 | TRIPCODE4 | varchar | 3 | Yes |  |
 | TRIPCODE5 | varchar | 3 | Yes |  |
 | AUTHSRCE1 | varchar | 1 | Yes |  |
 | AUTHSRCE2 | varchar | 1 | Yes |  |
 | AUTHSRCE3 | varchar | 1 | Yes |  |
 | AUTHSRCE4 | varchar | 1 | Yes |  |
 | AUTHSRCE5 | varchar | 1 | Yes |  |
 | AUTHTYPE1 | varchar | 1 | Yes |  |
 | AUTHTYPE2 | varchar | 1 | Yes |  |
 | AUTHTYPE3 | varchar | 1 | Yes |  |
 | AUTHTYPE4 | varchar | 1 | Yes |  |
 | AUTHTYPE5 | varchar | 1 | Yes |  |
 | CURPRD1 | numeric |  | Yes |  |
 | CURPRD2 | numeric |  | Yes |  |
 | CURPRD3 | numeric |  | Yes |  |
 | CURPRD4 | numeric |  | Yes |  |
 | CURPRD5 | numeric |  | Yes |  |
 | PRVPRD1 | numeric |  | Yes |  |
 | PRVPRD2 | numeric |  | Yes |  |
 | PRVPRD3 | numeric |  | Yes |  |
 | PRVPRD4 | numeric |  | Yes |  |
 | PRVPRD5 | numeric |  | Yes |  |
 | AMTAUTH1 | numeric |  | Yes |  |
 | AMTAUTH2 | numeric |  | Yes |  |
 | AMTAUTH3 | numeric |  | Yes |  |
 | AMTAUTH4 | numeric |  | Yes |  |
 | AMTAUTH5 | numeric |  | Yes |  |
 | UPTRAN | varchar | 1 | Yes |  |
 | PASSWORD | varchar | 8 | Yes |  |
 | COMMENT1 | varchar | 100 | Yes |  |
 | DISAB | varchar | 3 | Yes |  |
 | ESCORT | varchar | 1 | Yes |  |
 | DWELL | numeric |  | Yes |  |
 | LANGUAGE | varchar | 1 | Yes |  |
 | MISC1 | varchar | 1 | Yes |  |
 | CAPADJ | numeric |  | Yes |  |
 | upjdate | numeric |  | Yes |  |
 | XUPTIME | numeric |  | Yes |  |
 | PHYSICIAN | varchar | 100 | Yes |  |
 | PHYS_LIC | varchar | 12 | Yes |  |
 | REGION | varchar | 4 | Yes |  |
 | PHTYPE | varchar | 1 | Yes |  |
 | EMPHTYPE | varchar | 1 | Yes |  |
 | EMPHOWN | varchar | 1 | Yes |  |
 | PHYPHONE | varchar | 13 | Yes |  |
 | CASEPHONE | varchar | 13 | Yes |  |
 | CERTIFYBY | varchar | 10 | Yes |  |
 | CERTNAME | varchar | 20 | Yes |  |
 | CERT_LIC | varchar | 12 | Yes |  |
 | CERTDATE | varchar | 8 | Yes |  |
 | NUMINHOUSE | numeric |  | Yes |  |
 | RECSTAT | varchar | 1 | Yes |  |
 | ADA | varchar | 1 | Yes |  |
 | ZIPEXT | varchar | 4 | Yes |  |
 | PHEXT | varchar | 4 | Yes |  |
 | CITYOFRES | varchar | 20 | Yes |  |
 | OWNVEH | varchar | 1 | Yes |  |
 | OTHDRV | varchar | 1 | Yes |  |
 | HEADHOUSE | varchar | 1 | Yes |  |
 | HHNAME | varchar | 30 | Yes |  |
 | OTHINSUR | varchar | 1 | Yes |  |
 | PCA | varchar | 1 | Yes |  |
 | OTHID | varchar | 13 | Yes |  |
 | SERMODE | varchar | 3 | Yes |  |
 | DIAG1 | varchar | 5 | Yes |  |
 | DIAG2 | varchar | 5 | Yes |  |
 | PRIORAUTH | varchar | 12 | Yes |  |
 | PASTDATE | varchar | 8 | Yes |  |
 | PAENDATE | varchar | 8 | Yes |  |
 | PRTA4NOTES | varchar | 1 | Yes |  |
 | LASTSERV | numeric |  | Yes |  |
 | DOB | datetime |  | Yes |  |
 | GISY | numeric |  | Yes |  |
 | LastDateofService | datetime |  | Yes |  |
 | LastUpTime | varchar | 5 | Yes |  |
 | LastUpUser | varchar | 30 | Yes |  |
 | GisLatitude | varchar | 50 | Yes |  |
 | GisLongitude | varchar | 50 | Yes |  |
 | County | varchar | 50 | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | Phyphoneext | varchar | 10 | Yes |  |
 | Casephoneext | varchar | 10 | Yes |  |
 | SuspendStart | datetime |  | Yes |  |
 | SuspendEnd | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Clients | clustered, unique, primary key located on PRIMARY | ID


Table ptms..CustomReports

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Report | varchar | 12 | Yes |  |
 | Purpose | varchar | 50 | Yes |  |
 | Developer | varchar | 50 | Yes |  |
 | Created | datetime |  | Yes |  |
 | LastUpdate | datetime |  | Yes |  |
 | Output | varchar | 1 | Yes |  |
 | tripcode | varchar | 70 | Yes |  |
 | Note2 | varchar | 70 | Yes |  |
 | Note3 | varchar | 70 | Yes |  |
 | Note4 | varchar | 70 | Yes |  |
 | Note5 | varchar | 70 | Yes |  |
 | Note6 | varchar | 70 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_CustomReports | clustered, unique, primary key located on PRIMARY | ID
U_Report | nonclustered, unique located on PRIMARY | Report


Table ptms..Destinations

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Zone | varchar | 6 | Yes |  |
 | Zonname | varchar | 25 | Yes |  |
 | Destination | varchar | 50 | Yes |  |
 | Facility | varchar | 1 | Yes |  |
 | Address1 | varchar | 50 | Yes |  |
 | Address2 | varchar | 50 | Yes |  |
 | City | varchar | 30 | Yes |  |
 | State | varchar | 2 | Yes |  |
 | Zipcode | varchar | 5 | Yes |  |
 | Phone | varchar | 13 | Yes |  |
 | DriverInstructions | varchar | 100 | Yes |  |
 | ProviderNumber | varchar | 20 | Yes |  |
 | Fax | varchar | 13 | Yes |  |
 | ActiveDestination | varchar | 1 | Yes |  |
 | ProviderLicense | varchar | 20 | Yes |  |
 | ProviderType | varchar | 4 | Yes |  |
 | Gisx | numeric |  | Yes |  |
 | Gisy | numeric |  | Yes |  |
 | Note1 | varchar | 50 | Yes |  |
 | NPI | varchar | 12 | Yes |  |
 | ZipExtension | numeric |  | Yes |  |
 | RecordTypeStreets | varchar | 15 | Yes |  |
 | DefaultPurpose | varchar | 3 | Yes |  |
 | InsurancePlaceOfService | varchar | 1 | Yes |  |
 | MedicaidPlaceOfService | varchar | 2 | Yes |  |
 | PersonOrCompany | varchar | 1 | Yes |  |
 | ProviderFirstName | varchar | 10 | Yes |  |
 | ProviderLastName | varchar | 20 | Yes |  |
 | ProviderMI | varchar | 1 | Yes |  |
 | DestinationNumber | varchar | 20 | Yes |  |
 | LocationType | varchar | 1 | Yes |  |
 | ProcedureModifier | varchar | 1 | Yes |  |
 | SeviceMode | varchar | 3 | Yes |  |
 | GisLatitude | varchar | 50 | Yes |  |
 | GisLongitude | varchar | 50 | Yes |  |
 | Alias | varchar | 1 | Yes |  |
 | County | varchar | 50 | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | LastUpDate | datetime |  | Yes |  |
 | LastUpTime | varchar | 5 | Yes |  |
 | LastUpUser | varchar | 30 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Destinations | clustered, unique, primary key located on PRIMARY | ID
U_Destination | nonclustered, unique located on PRIMARY | Destination


Table ptms..Disabilities

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Disability | varchar | 3 | Yes |  |
 | Description | varchar | 25 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Disabilities | clustered, unique, primary key located on PRIMARY | ID
U_Disability | nonclustered, unique located on PRIMARY | Disability


Table ptms..Drivers

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Driver | varchar | 3 | Yes |  |
 | Provider | varchar | 4 | Yes |  |
 | Vendor | varchar | 30 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | MI | varchar | 1 | Yes |  |
 | LastName | varchar | 15 | Yes |  |
 | DrugTestDate | datetime |  | Yes |  |
 | DrugTestResult | varchar | 30 | Yes |  |
 | Misc1 | varchar | 6 | Yes |  |
 | Misc2 | varchar | 4 | Yes |  |
 | Filler10 | varchar | 10 | Yes |  |
 | LicenseType | varchar | 30 | Yes |  |
 | LicenseNumber | varchar | 15 | Yes |  |
 | LicenseExpirationDate | datetime |  | Yes |  |
 | LicenseIssueDate | datetime |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Drivers | clustered, unique, primary key located on PRIMARY | ID
U_Driver | nonclustered, unique located on PRIMARY | Driver


Table ptms..GISParameters

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | keynum | numeric |  | Yes |  |
 | NorthSouthReferenceZone | numeric |  | Yes |  |
 | WestEastReferenceZone | numeric |  | Yes |  |
 | GISYReference | numeric |  | Yes |  |
 | GISXReference | numeric |  | Yes |  |
 | MilesPerZone | numeric |  | Yes |  |
 | NorthSouthDirection | varchar | 1 | Yes |  |
 | ReferenceLocationDescription | varchar | 35 | Yes |  |
 | StreetsPath | varchar | 50 | Yes |  |
 | PtmsPath | varchar | 50 | Yes |  |
 | expath | varchar | 65 | Yes |  |
 | QueryUserToCalcZone | varchar | 1 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_GISParameters | clustered, unique, primary key located on PRIMARY | ID


Table ptms..MiscellaneousCodes

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Fieldname | varchar | 10 | Yes |  |
 | Code | varchar | 10 | Yes |  |
 | Description | varchar | 25 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_MiscellaneousCodes | clustered, unique, primary key located on PRIMARY | ID


Table ptms..MiscellaneousCodesValues

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | MiscCode | varchar | 255 | Yes |  |
 | MiscCodeDesc | varchar | 255 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK__MiscellaneousCod__2C3393D0 | clustered, unique, primary key located on PRIMARY | ID


Table ptms..NewPas

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Medid | varchar | 16 | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | MI | varchar | 1 | Yes |  |
 | Confirmno | numeric |  | Yes |  |
 | Startdate | datetime |  | Yes |  |
 | STARTJDATE | numeric |  | Yes |  |
 | Stopdate | datetime |  | Yes |  |
 | STOPJDATE | numeric |  | Yes |  |
 | PROCED0 | varchar | 5 | Yes |  |
 | QUANAPP | numeric |  | Yes |  |
 | AMNTAPP | money |  | Yes |  |
 | QUANUSE | numeric |  | Yes |  |
 | AMNTUSE | numeric |  | Yes |  |
 | PROVIDER | varchar | 4 | Yes |  |
 | STATUS | varchar | 1 | Yes |  |
 | INVNUM | varchar | 8 | Yes |  |
 | PROVNUM | varchar | 8 | Yes |  |
 | CATEGORY | varchar | 4 | Yes |  |
 | REASON | varchar | 2 | Yes |  |
 | PADELETE | varchar | 1 | Yes |  |
 | LASTDATE | datetime |  | Yes |  |
 | DAYS | numeric |  | Yes |  |
 | RATE0 | money |  | Yes |  |
 | RENPROV | varchar | 8 | Yes |  |
 | XUPDATE | datetime |  | Yes |  |
 | XUPJDATE | numeric |  | Yes |  |
 | LASTSTAT | varchar | 1 | Yes |  |
 | OLDPROC | varchar | 5 | Yes |  |
 | PROCED1 | varchar | 5 | Yes |  |
 | CATEG1 | varchar | 4 | Yes |  |
 | RATE1 | money |  | Yes |  |
 | QUANAPP1 | numeric |  | Yes |  |
 | DAYS1 | numeric |  | Yes |  |
 | AMNTAPP1 | money |  | Yes |  |
 | PROCED2 | varchar | 5 | Yes |  |
 | CATEG2 | varchar | 4 | Yes |  |
 | RATE2 | money |  | Yes |  |
 | QUANAPP2 | numeric |  | Yes |  |
 | DAYS2 | numeric |  | Yes |  |
 | AMNTAPP2 | money |  | Yes |  |
 | PROCED3 | varchar | 5 | Yes |  |
 | CATEG3 | varchar | 4 | Yes |  |
 | RATE3 | money |  | Yes |  |
 | QUANAPP3 | numeric |  | Yes |  |
 | DAYS3 | numeric |  | Yes |  |
 | AMNTAPP3 | money |  | Yes |  |
 | KEYDATE | numeric |  | Yes |  |
 | PADELETE1 | varchar | 1 | Yes |  |
 | PADELETE2 | varchar | 1 | Yes |  |
 | PADELETE3 | varchar | 1 | Yes |  |
 | ESCORT | varchar | 1 | Yes |  |
 | PCA | varchar | 1 | Yes |  |
 | RENEW | bit |  | Yes |  |
 | CONVERT | varchar | 1 | Yes |  |
 | ERRSTAT | varchar | 1 | Yes |  |
 | NEWPA | numeric |  | Yes |  |
 | STATUS1 | varchar | 1 | Yes |  |
 | STATUS2 | varchar | 1 | Yes |  |
 | STATUS3 | varchar | 1 | Yes |  |
 | LASTSTAT1 | varchar | 1 | Yes |  |
 | LASTSTAT2 | varchar | 1 | Yes |  |
 | LASTSTAT3 | varchar | 1 | Yes |  |
 | KEYDELDATE | datetime |  | Yes |  |
 | PTMSUSER | varchar | 30 | Yes |  |
 | FIRSTDATE | datetime |  | Yes |  |
 | Destination | varchar | 50 | Yes |  |
 | FIRSTUSER | varchar | 30 | Yes |  |
 | PREVUPDATE | datetime |  | Yes |  |
 | PREVSTATUS | varchar | 1 | Yes |  |
 | PROVTYPE | varchar | 3 | Yes |  |
 | PANUM | varchar | 15 | Yes |  |
 | REQVER | varchar | 1 | Yes |  |
 | CANCTR | numeric |  | Yes |  |
 | NPI | varchar | 12 | Yes |  |
 | Verified | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | DestinationID | numeric |  | Yes |  |
 | ClientID | varchar | 10 | Yes |  |
 | ReferenceNumber | varchar | 20 | Yes |  |


Table ptms..NYCmn

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | ClientID | varchar | 10 | Yes |  |
 | MODE | varchar | 10 | Yes |  |
 | STARTDATE | datetime |  | Yes |  |
 | STOPDATE | datetime |  | Yes |  |
 | MEDID | varchar | 16 | Yes |  |
 | SSN | varchar | 11 | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 15 | Yes |  |
 | DOB | varchar | 10 | Yes |  |
 | ADDRESS1 | varchar | 50 | Yes |  |
 | CITY | varchar | 25 | Yes |  |
 | STATE | varchar | 2 | Yes |  |
 | ZIPCODE | varchar | 5 | Yes |  |
 | A1 | varchar | 3 | Yes |  |
 | A2 | varchar | 3 | Yes |  |
 | A3 | varchar | 3 | Yes |  |
 | A4 | varchar | 3 | Yes |  |
 | A5 | varchar | 3 | Yes |  |
 | DIAGNOSIS1 | varchar | 10 | Yes |  |
 | DIAGNOSIS2 | varchar | 10 | Yes |  |
 | DIAGNOSIS3 | varchar | 10 | Yes |  |
 | DIAGNOSIS4 | varchar | 10 | Yes |  |
 | DIAGNOSIS5 | varchar | 10 | Yes |  |
 | WHYDIAG | varchar | 250 | Yes |  |
 | REQWCSCOX | bit |  | Yes |  |
 | REQASSIST | bit |  | Yes |  |
 | ESCORT | bit |  | Yes |  |
 | LIFEEQUIP | bit |  | Yes |  |
 | REQEMT | bit |  | Yes |  |
 | RECLINEMED | bit |  | Yes |  |
 | RECLINEPSY | bit |  | Yes |  |
 | REQVEHO2 | bit |  | Yes |  |
 | DESTIN | varchar | 50 | Yes |  |
 | DADDRESS1 | varchar | 50 | Yes |  |
 | DCITY | varchar | 25 | Yes |  |
 | DSTATE | varchar | 2 | Yes |  |
 | DZIPCODE | varchar | 10 | Yes |  |
 | PROVNUM | varchar | 20 | Yes |  |
 | NPI | varchar | 10 | Yes |  |
 | DOCTOR | varchar | 50 | Yes |  |
 | SIGNDATE | datetime |  | Yes |  |
 | HOSPNAME | varchar | 50 | Yes |  |
 | DOCADDRESS | varchar | 50 | Yes |  |
 | DOCCITY | varchar | 25 | Yes |  |
 | DOCSTATE | varchar | 2 | Yes |  |
 | DOCZIPCODE | varchar | 5 | Yes |  |
 | DOCPHONE | varchar | 13 | Yes |  |
 | WORKERNAME | varchar | 50 | Yes |  |
 | WORKERTITL | varchar | 30 | Yes |  |
 | WORKERPHON | varchar | 13 | Yes |  |
 | EnterUser | varchar | 30 | Yes |  |
 | EnterDate | datetime |  | Yes |  |
 | EnterTime | varchar | 5 | Yes |  |
 | LastUser | varchar | 30 | Yes |  |
 | LastDate | datetime |  | Yes |  |
 | LastTime | varchar | 5 | Yes |  |
 | Renewtrip | bit |  | Yes |  |
 | NOTES | varchar | 250 | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | sex | varchar | 1 | Yes |  |
 | Diagnosis6 | varchar | 10 | Yes |  |
 | Address2 | varchar | 50 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_NYCmn | clustered, unique, primary key located on PRIMARY | ID


Table ptms..NYParates

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Tripcode | varchar | 3 | Yes |  |
 | Reason | varchar | 2 | Yes |  |
 | FProcedure | varchar | 5 | Yes |  |
 | Rate0 | money |  | Yes |  |
 | EscortRate | money |  | Yes |  |
 | Category | varchar | 4 | Yes |  |
 | Description | varchar | 25 | Yes |  |
 | MileRate | money |  | Yes |  |
 | RateType | varchar | 1 | Yes |  |
 | Mprocedure | varchar | 5 | Yes |  |
 | Gprocedure | varchar | 5 | Yes |  |
 | Gtripcode | varchar | 3 | Yes |  |
 | Mtripcode | varchar | 3 | Yes |  |
 | DisplayTC | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_NYParates | clustered, unique, primary key located on PRIMARY | ID
U_Tripcode | nonclustered, unique located on PRIMARY | Tripcode


Table ptms..NYPriorApprovals

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Medid | varchar | 16 | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | MI | varchar | 1 | Yes |  |
 | Confirmno | numeric |  | Yes |  |
 | Startdate | datetime |  | Yes |  |
 | STARTJDATE | numeric |  | Yes |  |
 | Stopdate | datetime |  | Yes |  |
 | STOPJDATE | numeric |  | Yes |  |
 | PROCED0 | varchar | 5 | Yes |  |
 | QUANAPP | numeric |  | Yes |  |
 | AMNTAPP | money |  | Yes |  |
 | QUANUSE | numeric |  | Yes |  |
 | AMNTUSE | numeric |  | Yes |  |
 | PROVIDER | varchar | 4 | Yes |  |
 | STATUS | varchar | 1 | Yes |  |
 | INVNUM | varchar | 8 | Yes |  |
 | PROVNUM | varchar | 8 | Yes |  |
 | CATEGORY | varchar | 4 | Yes |  |
 | REASON | varchar | 2 | Yes |  |
 | PADELETE | varchar | 1 | Yes |  |
 | LASTDATE | datetime |  | Yes |  |
 | DAYS | numeric |  | Yes |  |
 | RATE0 | money |  | Yes |  |
 | RENPROV | varchar | 8 | Yes |  |
 | XUPDATE | datetime |  | Yes |  |
 | XUPJDATE | numeric |  | Yes |  |
 | LASTSTAT | varchar | 1 | Yes |  |
 | OLDPROC | varchar | 5 | Yes |  |
 | PROCED1 | varchar | 5 | Yes |  |
 | CATEG1 | varchar | 4 | Yes |  |
 | RATE1 | money |  | Yes |  |
 | QUANAPP1 | numeric |  | Yes |  |
 | DAYS1 | numeric |  | Yes |  |
 | AMNTAPP1 | money |  | Yes |  |
 | PROCED2 | varchar | 5 | Yes |  |
 | CATEG2 | varchar | 4 | Yes |  |
 | RATE2 | money |  | Yes |  |
 | QUANAPP2 | numeric |  | Yes |  |
 | DAYS2 | numeric |  | Yes |  |
 | AMNTAPP2 | money |  | Yes |  |
 | PROCED3 | varchar | 5 | Yes |  |
 | CATEG3 | varchar | 4 | Yes |  |
 | RATE3 | money |  | Yes |  |
 | QUANAPP3 | numeric |  | Yes |  |
 | DAYS3 | numeric |  | Yes |  |
 | AMNTAPP3 | money |  | Yes |  |
 | KEYDATE | numeric |  | Yes |  |
 | PADELETE1 | varchar | 1 | Yes |  |
 | PADELETE2 | varchar | 1 | Yes |  |
 | PADELETE3 | varchar | 1 | Yes |  |
 | ESCORT | varchar | 1 | Yes |  |
 | PCA | varchar | 1 | Yes |  |
 | RENEW | bit |  | Yes |  |
 | CONVERT | varchar | 1 | Yes |  |
 | ERRSTAT | varchar | 1 | Yes |  |
 | NEWPA | numeric |  | Yes |  |
 | STATUS1 | varchar | 1 | Yes |  |
 | STATUS2 | varchar | 1 | Yes |  |
 | STATUS3 | varchar | 1 | Yes |  |
 | LASTSTAT1 | varchar | 1 | Yes |  |
 | LASTSTAT2 | varchar | 1 | Yes |  |
 | LASTSTAT3 | varchar | 1 | Yes |  |
 | KEYDELDATE | datetime |  | Yes |  |
 | PTMSUSER | varchar | 30 | Yes |  |
 | FIRSTDATE | datetime |  | Yes |  |
 | Destination | varchar | 50 | Yes |  |
 | FIRSTUSER | varchar | 30 | Yes |  |
 | PREVUPDATE | datetime |  | Yes |  |
 | PREVSTATUS | varchar | 1 | Yes |  |
 | PROVTYPE | varchar | 3 | Yes |  |
 | PANUM | varchar | 15 | Yes |  |
 | REQVER | varchar | 1 | Yes |  |
 | CANCTR | numeric |  | Yes |  |
 | NPI | varchar | 12 | Yes |  |
 | Verified | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | DestinationID | numeric |  | Yes |  |
 | ClientID | varchar | 10 | Yes |  |
 | ReferenceNumber | varchar | 20 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_NYPriorApprovals | clustered, unique, primary key located on PRIMARY | ID
U_MedidConfirmno | nonclustered, unique located on PRIMARY | Medid, Confirmno


Table ptms..PaSharedRideCodes

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Type | varchar | 1 | Yes |  |
 | Agency | varchar | 3 | Yes |  |
 | Funding | varchar | 3 | Yes |  |
 | Purpose | varchar | 3 | Yes |  |
 | BillingType | varchar | 1 | Yes |  |
 | Rate | money |  | Yes |  |
 | Tripcode | varchar | 3 | Yes |  |
 | BoardingFarePercentage | numeric |  | Yes |  |
 | MinimumBoardingFare | numeric |  | Yes |  |
 | StateReportColumn | varchar | 1 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_PaSharedRideCodes | clustered, unique, primary key located on PRIMARY | ID
U_AgencyFundingPurposeTripcode | nonclustered, unique located on PRIMARY | Agency, Funding, Purpose, Tripcode


Table ptms..ProcedureMatching

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | TripcodeCategory | varchar | 255 | Yes |  |
 | ProviderCategory | varchar | 255 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK__ProcedureMatchin__756D6ECB | clustered, unique, primary key located on PRIMARY | ID


Table ptms..Providers

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Provider | varchar | 4 | Yes |  |
 | Description | varchar | 30 | Yes |  |
 | LastName | varchar | 15 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | Title | varchar | 30 | Yes |  |
 | ADDRESS1 | varchar | 40 | Yes |  |
 | ADDRESS2 | varchar | 40 | Yes |  |
 | CITY | varchar | 20 | Yes |  |
 | STATE | varchar | 2 | Yes |  |
 | ZIPCODE | varchar | 5 | Yes |  |
 | PHONE1 | varchar | 13 | Yes |  |
 | EXT1 | varchar | 4 | Yes |  |
 | PHONE2 | varchar | 13 | Yes |  |
 | EXT2 | varchar | 4 | Yes |  |
 | NOTE | varchar | 60 | Yes |  |
 | NPI | varchar | 12 | Yes |  |
 | PROVTYPE | varchar | 1 | Yes |  |
 | SERVTYPE | varchar | 1 | Yes |  |
 | DROPRATE | money |  | Yes |  |
 | SERVAREA | varchar | 10 | Yes |  |
 | RATEPERHR | money |  | Yes |  |
 | RATEPERMIL | money |  | Yes |  |
 | Postcode | varchar | 8 | Yes |  |
 | FEDTAXID | varchar | 9 | Yes |  |
 | OTHERID | varchar | 12 | Yes |  |
 | FAXNO | varchar | 13 | Yes |  |
 | CATEGORY | varchar | 4 | Yes |  |
 | TAG | varchar | 1 | Yes |  |
 | EMAIL | varchar | 50 | Yes |  |
 | AllowWebVerification | bit |  | Yes |  |
 | Medcode | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Providers | clustered, unique, primary key located on PRIMARY | ID
U_Provider | nonclustered, unique located on PRIMARY | Provider


Table ptms..ReportOptions

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Name1 | varchar | 255 | Yes |  |
 | Name2 | varchar | 255 | Yes |  |
 | Address1 | varchar | 255 | Yes |  |
 | Address2 | varchar | 255 | Yes |  |
 | City | varchar | 255 | Yes |  |
 | State | varchar | 255 | Yes |  |
 | Zipcode | varchar | 255 | Yes |  |
 | Comment | varchar | 255 | Yes |  |
 | Phone | varchar | 255 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK__ReportOptions__33D4B598 | clustered, unique, primary key located on PRIMARY | ID


Table ptms..RevenueCodes

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Codetype | varchar | 1 | Yes |  |
 | CodeLabel | varchar | 20 | Yes |  |
 | Code | varchar | 3 | Yes |  |
 | Description | varchar | 30 | Yes |  |
 | MaximumAllowableFare | money |  | Yes |  |
 | ServiceOverheadRate | money |  | Yes |  |
 | InvoiceType | varchar | 1 | Yes |  |
 | DefaultDestination | varchar | 50 | Yes |  |
 | DefaultZone | varchar | 6 | Yes |  |
 | DefaultAmbTripcode | varchar | 3 | Yes |  |
 | DefaultWCTripcodes | varchar | 3 | Yes |  |
 | UseCashRates | bit |  | Yes |  |
 | UseCashFares | bit |  | Yes |  |
 | GenerateNewClientsServiceRequest | bit |  | Yes |  |
 | UseTripTickets | bit |  | Yes |  |
 | ClientMustPrePayService | bit |  | Yes |  |
 | ChargeFullFarePurposeCode | bit |  | Yes |  |
 | newfield2 | varchar | 1 | Yes |  |
 | DefaultPickupTime | varchar | 5 | Yes |  |
 | DefaultDestinationTime | varchar | 5 | Yes |  |
 | SkipPostingforTripVerification | bit |  | Yes |  |
 | PostTripsAsVerified | bit |  | Yes |  |
 | Medcode | bit |  | Yes |  |
 | RequiresCMN | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_RevenueCodes | clustered, unique, primary key located on PRIMARY | ID
U_CodetypeCode | nonclustered, unique located on PRIMARY | Codetype, Code


Table ptms..Schedule

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Vehicle | varchar | 4 | Yes |  |
 | DefaultVehicle | varchar | 3 | Yes |  |
 | DATE | varchar | 8 | Yes |  |
 | JDATE | numeric |  | Yes |  |
 | Day | varchar | 3 | Yes |  |
 | DayNumber | numeric |  | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | ClientID | varchar | 10 | Yes |  |
 | Tripcode | varchar | 3 | Yes |  |
 | TakeOrReturn | varchar | 1 | Yes |  |
 | PickupLocation | varchar | 50 | Yes |  |
 | PickupTime | varchar | 5 | Yes |  |
 | DefaultPickupTime | varchar | 5 | Yes |  |
 | Destination | varchar | 50 | Yes |  |
 | DropTime | varchar | 5 | Yes |  |
 | DefaultDropTime | varchar | 5 | Yes |  |
 | ResetDate | datetime |  | Yes |  |
 | seqnum | numeric |  | Yes |  |
 | Agency | varchar | 3 | Yes |  |
 | Funding | varchar | 3 | Yes |  |
 | Purpose | varchar | 3 | Yes |  |
 | Special | varchar | 3 | Yes |  |
 | Fare | money |  | Yes |  |
 | DriverInstructions | varchar | 100 | Yes |  |
 | rpzoncode | varchar | 6 | Yes |  |
 | tpzoncode | varchar | 6 | Yes |  |
 | StartDate | datetime |  | Yes |  |
 | StopDate | datetime |  | Yes |  |
 | startjdate | numeric |  | Yes |  |
 | stopjdate | numeric |  | Yes |  |
 | Status | varchar | 1 | Yes |  |
 | Keydate | numeric |  | Yes |  |
 | Keytime | varchar | 5 | Yes |  |
 | Verified | varchar | 1 | Yes |  |
 | Miles | numeric |  | Yes |  |
 | Run | varchar | 1 | Yes |  |
 | uptran | varchar | 1 | Yes |  |
 | ScheduleRecordNumber | numeric |  | Yes |  |
 | TravelMinutes | numeric |  | Yes |  |
 | password | varchar | 8 | Yes |  |
 | Attendant | numeric |  | Yes |  |
 | Escort | varchar | 1 | Yes |  |
 | fine | money |  | Yes |  |
 | efare | money |  | Yes |  |
 | efine | money |  | Yes |  |
 | paddress1 | varchar | 50 | Yes |  |
 | paddress2 | varchar | 50 | Yes |  |
 | daddress1 | varchar | 50 | Yes |  |
 | daddress2 | varchar | 50 | Yes |  |
 | ReferenceNumber | varchar | 20 | Yes |  |
 | Provider | varchar | 4 | Yes |  |
 | SuspendCancellationFlag | varchar | 1 | Yes |  |
 | refsdate | datetime |  | Yes |  |
 | refedate | datetime |  | Yes |  |
 | quanapp | numeric |  | Yes |  |
 | pastarjd | numeric |  | Yes |  |
 | pastopjd | numeric |  | Yes |  |
 | Note | varchar | 100 | Yes |  |
 | ProcedureModifier | varchar | 2 | Yes |  |
 | Renew | bit |  | Yes |  |
 | UserTripRequest | varchar | 30 | Yes |  |
 | DateTripRequest | datetime |  | Yes |  |
 | TimeTripRequest | varchar | 5 | Yes |  |
 | ActualPickupTime | varchar | 5 | Yes |  |
 | ActualDropTime | varchar | 5 | Yes |  |
 | DispatchTime | varchar | 5 | Yes |  |
 | OdometerOff | numeric |  | Yes |  |
 | OdometerOn | numeric |  | Yes |  |
 | CalculatedMiles | numeric |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | PickupLocationID | numeric |  | Yes |  |
 | PickupLocationSource | varchar | 1 | Yes |  |
 | DestinationID | numeric |  | Yes |  |
 | DestinationSource | varchar | 1 | Yes |  |
 | TripRequestDate | datetime |  | Yes |  |
 | Driver | varchar | 3 | Yes |  |
 | LastUpdate | datetime |  | Yes |  |
 | LastUpTime | varchar | 5 | Yes |  |
 | LastUpUser | varchar | 30 | Yes |  |
 | StartDate1 | datetime |  | Yes |  |
 | StopDate1 | datetime |  | Yes |  |
 | StartDate2 | datetime |  | Yes |  |
 | StopDate2 | datetime |  | Yes |  |
 | StartDate3 | datetime |  | Yes |  |
 | StopDate3 | datetime |  | Yes |  |
 | StartDate4 | datetime |  | Yes |  |
 | StopDate4 | datetime |  | Yes |  |
 | StartDate5 | datetime |  | Yes |  |
 | StopDate5 | datetime |  | Yes |  |
 | pgisx | varchar | 12 | Yes |  |
 | pgisy | varchar | 12 | Yes |  |
 | dgisx | varchar | 12 | Yes |  |
 | dgisy | varchar | 12 | Yes |  |
 | pgislatitude | varchar | 50 | Yes |  |
 | pgislongitude | varchar | 50 | Yes |  |
 | dgislatitude | varchar | 50 | Yes |  |
 | dgislongitude | varchar | 50 | Yes |  |
 | StatusReason | varchar | 50 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Schedule | clustered, unique, primary key located on PRIMARY | ID


Table ptms..ScheduledTripSuspensions

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | ClientID | varchar | 10 | Yes |  |
 | ScheduleRecordNumber | numeric |  | Yes |  |
 | StopDate0 | datetime |  | Yes |  |
 | Startdate0 | datetime |  | Yes |  |
 | Stopjdate | numeric |  | Yes |  |
 | Starjdate | numeric |  | Yes |  |
 | SuspendedCancelled0 | varchar | 1 | Yes |  |
 | SuspendedCancelled1 | varchar | 1 | Yes |  |
 | SuspendedCancelled2 | varchar | 1 | Yes |  |
 | Filler5 | varchar | 5 | Yes |  |
 | Stopdate1 | datetime |  | Yes |  |
 | Startdate1 | datetime |  | Yes |  |
 | Stopj1 | numeric |  | Yes |  |
 | Starj1 | numeric |  | Yes |  |
 | Stopdate2 | datetime |  | Yes |  |
 | Startdate2 | datetime |  | Yes |  |
 | Stopj2 | numeric |  | Yes |  |
 | Starj2 | numeric |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_ScheduledTripSuspensions | clustered, unique, primary key located on PRIMARY | ID
U_ClientIDScheduleRecordNumber | nonclustered, unique located on PRIMARY | ClientID, ScheduleRecordNumber


Table ptms..SchedulingCapacityPerHour

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | ScheduleHour | varchar | 5 | Yes |  |
 | DefaultAmbCapacity | numeric |  | Yes |  |
 | DefaultWCCapacity | numeric |  | Yes |  |
 | DateRestrictedAmbCapacity | numeric |  | Yes |  |
 | DateRestrictedWCCapacity | numeric |  | Yes |  |
 | DateRestrictionStartDate | datetime |  | Yes |  |
 | DateRestrictionStopDate | datetime |  | Yes |  |
 | starjdate | numeric |  | Yes |  |
 | stopjdate | numeric |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_SchedulingCapacityPerHour | clustered, unique, primary key located on PRIMARY | ID
U_ScheduleHour | nonclustered, unique located on PRIMARY | ScheduleHour


Table ptms..ServiceRequests

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | MI | varchar | 1 | Yes |  |
 | ClientID | varchar | 10 | Yes |  |
 | SSN | varchar | 11 | Yes |  |
 | MedicaidID | varchar | 16 | Yes |  |
 | HomePhone | varchar | 13 | Yes |  |
 | LastUpdate | datetime |  | Yes |  |
 | DATE | varchar | 8 | Yes |  |
 | Vehicle | varchar | 4 | Yes |  |
 | AGENCY | varchar | 3 | Yes |  |
 | FUNDING | varchar | 3 | Yes |  |
 | PURPOSE | varchar | 3 | Yes |  |
 | TakeDestination | varchar | 50 | Yes |  |
 | TakeDropTime | varchar | 5 | Yes |  |
 | TakePickupLocation | varchar | 50 | Yes |  |
 | TakePickupTime | varchar | 5 | Yes |  |
 | tpzoncode | varchar | 6 | Yes |  |
 | TakeRun | varchar | 1 | Yes |  |
 | tpzonname | varchar | 25 | Yes |  |
 | ReturnDestination | varchar | 50 | Yes |  |
 | ReturnDropTime | varchar | 5 | Yes |  |
 | ReturnPickupLocation | varchar | 50 | Yes |  |
 | ReturnPickupTime | varchar | 5 | Yes |  |
 | rpzoncode | varchar | 6 | Yes |  |
 | ReturnRun | varchar | 1 | Yes |  |
 | rpzonname | varchar | 25 | Yes |  |
 | DriverInstructions | varchar | 100 | Yes |  |
 | Special | varchar | 3 | Yes |  |
 | TakeMonday | varchar | 1 | Yes |  |
 | TakeTuesday | varchar | 1 | Yes |  |
 | TakeWednesday | varchar | 1 | Yes |  |
 | TakeThursday | varchar | 1 | Yes |  |
 | TakeFriday | varchar | 1 | Yes |  |
 | TakeSaturday | varchar | 1 | Yes |  |
 | TakeSunday | varchar | 1 | Yes |  |
 | TakeTripcode | varchar | 3 | Yes |  |
 | TakeFare | money |  | Yes |  |
 | ReturnMonday | varchar | 1 | Yes |  |
 | ReturnTuesday | varchar | 1 | Yes |  |
 | ReturnWednesday | varchar | 1 | Yes |  |
 | ReturnThursday | varchar | 1 | Yes |  |
 | ReturnFriday | varchar | 1 | Yes |  |
 | ReturnSaturday | varchar | 1 | Yes |  |
 | ReturnSunday | varchar | 1 | Yes |  |
 | ReturnTripcode | varchar | 3 | Yes |  |
 | ReturnFare | money |  | Yes |  |
 | TravelTime | numeric |  | Yes |  |
 | Miles | numeric |  | Yes |  |
 | uptran | varchar | 1 | Yes |  |
 | password | varchar | 8 | Yes |  |
 | StartDate | datetime |  | Yes |  |
 | ServiceRequestRecordNumber | numeric |  | Yes |  |
 | Provider | varchar | 4 | Yes |  |
 | vehcode1 | varchar | 3 | Yes |  |
 | disp | varchar | 1 | Yes |  |
 | disptime | numeric |  | Yes |  |
 | dispdate | numeric |  | Yes |  |
 | TakeRate | money |  | Yes |  |
 | ReturnRate | money |  | Yes |  |
 | ReferenceNumber | varchar | 20 | Yes |  |
 | timeoutbrk | varchar | 4 | Yes |  |
 | riders | numeric |  | Yes |  |
 | riders1 | numeric |  | Yes |  |
 | drvinstr1 | varchar | 40 | Yes |  |
 | Escort | varchar | 1 | Yes |  |
 | Attendant | varchar | 1 | Yes |  |
 | authdate | datetime |  | Yes |  |
 | epassword | varchar | 8 | Yes |  |
 | Weeks | numeric |  | Yes |  |
 | EndDate | datetime |  | Yes |  |
 | WeeksBetweenTrips | numeric |  | Yes |  |
 | ServiceMode | varchar | 3 | Yes |  |
 | ProcedureModifier | varchar | 2 | Yes |  |
 | Renew | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | TakePickupLocationID | numeric |  | Yes |  |
 | TakePickupLocationSource | varchar | 1 | Yes |  |
 | TakeDestinationID | numeric |  | Yes |  |
 | TakeDestinationSource | varchar | 1 | Yes |  |
 | ReturnPickupLocationID | numeric |  | Yes |  |
 | ReturnPickupLocationSource | varchar | 1 | Yes |  |
 | ReturnDestinationID | numeric |  | Yes |  |
 | ReturnDestinationSource | varchar | 1 | Yes |  |
 | LastUpTime | varchar | 5 | Yes |  |
 | LastUpUser | varchar | 30 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_ServiceRequests | clustered, unique, primary key located on PRIMARY | ID


Table ptms..States

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | TblState | varchar | 255 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK__States__2E1BDC42 | clustered, unique, primary key located on PRIMARY | ID


Table ptms..SysProcLog

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | SysProcDateSubmitted | datetime |  | Yes |  |
 | SysProcDate | datetime |  | Yes |  |
 | SysProcUser | varchar | 255 | Yes |  |
 | SysProcRecordsWritten | int |  | Yes |  |
 | SysProcFirstRecord | int |  | Yes |  |
 | SysProcLastRecord | int |  | Yes |  |
 | SysProcDeleted | bit |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK__SysProcLog__31EC6D26 | clustered, unique, primary key located on PRIMARY | ID


Table ptms..SystemParameters

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | KEYNUM | numeric |  | Yes |  |
 | DRIVE | varchar | 20 | Yes |  |
 | EXP1 | numeric |  | Yes |  |
 | EXP2 | numeric |  | Yes |  |
 | EXP3 | numeric |  | Yes |  |
 | CMP1 | numeric |  | Yes |  |
 | CMP2 | numeric |  | Yes |  |
 | CMP3 | numeric |  | Yes |  |
 | EXT | varchar | 3 | Yes |  |
 | COLOR1 | numeric |  | Yes |  |
 | COLOR2 | numeric |  | Yes |  |
 | COLOR3 | numeric |  | Yes |  |
 | COLOR4 | numeric |  | Yes |  |
 | COLOR5 | numeric |  | Yes |  |
 | COLOR6 | numeric |  | Yes |  |
 | OPSYS | varchar | 8 | Yes |  |
 | HELPON | varchar | 1 | Yes |  |
 | ALTID | varchar | 3 | Yes |  |
 | CROSSREF1 | varchar | 25 | Yes |  |
 | CROSSREF2 | varchar | 25 | Yes |  |
 | CROSSREF3 | varchar | 25 | Yes |  |
 | CLTIDNUM | numeric |  | Yes |  |
 | PICKUPD | varchar | 1 | Yes |  |
 | BILLUPD | varchar | 1 | Yes |  |
 | MAIDA | varchar | 3 | Yes |  |
 | MAIDF | varchar | 3 | Yes |  |
 | MAIDP | varchar | 3 | Yes |  |
 | ALTA | varchar | 3 | Yes |  |
 | ALTF | varchar | 3 | Yes |  |
 | ALTP | varchar | 3 | Yes |  |
 | TRAVEL | numeric |  | Yes |  |
 | MAXTRAVEL | numeric |  | Yes |  |
 | TRAN | numeric |  | Yes |  |
 | procdate | numeric |  | Yes |  |
 | PROCOPT1 | varchar | 1 | Yes |  |
 | PROCOPT2 | varchar | 1 | Yes |  |
 | PROCOPT3 | varchar | 1 | Yes |  |
 | SRIWRT | varchar | 1 | Yes |  |
 | BILLNOSHOW | varchar | 1 | Yes |  |
 | PZONES | numeric |  | Yes |  |
 | DZONES | numeric |  | Yes |  |
 | MATCH | numeric |  | Yes |  |
 | USEWIN | varchar | 1 | Yes |  |
 | PPMINUT | numeric |  | Yes |  |
 | PMMINUT | numeric |  | Yes |  |
 | DPMINUT | numeric |  | Yes |  |
 | DMMINUT | numeric |  | Yes |  |
 | USEZONASN | varchar | 1 | Yes |  |
 | AUTOCAP | varchar | 1 | Yes |  |
 | ROUTINE | varchar | 1 | Yes |  |
 | PSTIME1 | varchar | 5 | Yes |  |
 | PETIME1 | varchar | 5 | Yes |  |
 | PSTIME2 | varchar | 5 | Yes |  |
 | PETIME2 | varchar | 5 | Yes |  |
 | shareflag | varchar | 1 | Yes |  |
 | tripcode | varchar | 30 | Yes |  |
 | numveh | numeric |  | Yes |  |
 | GRPSEL | varchar | 1 | Yes |  |
 | GRP1CODE | varchar | 6 | Yes |  |
 | GRP2CODE | varchar | 6 | Yes |  |
 | INVOICE | numeric |  | Yes |  |
 | AGENCY | varchar | 3 | Yes |  |
 | FUNDING | varchar | 3 | Yes |  |
 | PURPOSE | varchar | 3 | Yes |  |
 | rankareas | varchar | 1 | Yes |  |
 | RECNUM | numeric |  | Yes |  |
 | RESETTBS | varchar | 1 | Yes |  |
 | AMBDWELL | numeric |  | Yes |  |
 | WCDWELL | numeric |  | Yes |  |
 | DEMANDDEL | varchar | 1 | Yes |  |
 | PEAKMPH | numeric |  | Yes |  |
 | NPEAKMPH | numeric |  | Yes |  |
 | SHIFT | varchar | 1 | Yes |  |
 | nopause | varchar | 1 | Yes |  |
 | VEHASSNSCN | varchar | 1 | Yes |  |
 | BROKER | varchar | 1 | Yes |  |
 | cltscn | varchar | 1 | Yes |  |
 | reqscn | varchar | 1 | Yes |  |
 | TRIPSHR | numeric |  | Yes |  |
 | DEFSTATE | varchar | 2 | Yes |  |
 | region | varchar | 4 | Yes |  |
 | WAITDISP | varchar | 1 | Yes |  |
 | PEAKMPZ | numeric |  | Yes |  |
 | NPEAKMPZ | numeric |  | Yes |  |
 | PCATC | varchar | 3 | Yes |  |
 | APPCITY | varchar | 1 | Yes |  |
 | PROFILE | varchar | 20 | Yes |  |
 | PROMPTPRT | varchar | 1 | Yes |  |
 | CUSVMAN | varchar | 1 | Yes |  |
 | AUTOAN | varchar | 1 | Yes |  |
 | ESCORTTC | varchar | 3 | Yes |  |
 | LASTJUDP | numeric |  | Yes |  |
 | REVJDATE | numeric |  | Yes |  |
 | VERSION | varchar | 4 | Yes |  |
 | SPANUM | numeric |  | Yes |  |
 | EPANUM | numeric |  | Yes |  |
 | AUTOANCS | varchar | 1 | Yes |  |
 | RECORQMN | varchar | 1 | Yes |  |
 | DEFCODE | varchar | 2 | Yes |  |
 | PICKUPDN | varchar | 1 | Yes |  |
 | BILLUPDN | varchar | 1 | Yes |  |
 | REQAVEHV | varchar | 1 | Yes |  |
 | DESTPOP | varchar | 1 | Yes |  |
 | AUTODATE | datetime |  | Yes |  |
 | RESTRICT | varchar | 1 | Yes |  |
 | PICKINFO2 | varchar | 1 | Yes |  |
 | POSTSUSP | varchar | 1 | Yes |  |
 | DemandDeleteDays | numeric |  | Yes |  |
 | ClientNotesFolder | varchar | 100 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_SystemParameters | clustered, unique, primary key located on PRIMARY | ID


Table ptms..Tripcodes

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Tripcode | varchar | 3 | Yes |  |
 | Description | varchar | 25 | Yes |  |
 | DisplayTC | bit |  | Yes |  |
 | MileageTC | bit |  | Yes |  |
 | Rate0 | money |  | Yes |  |
 | Miles | numeric |  | Yes |  |
 | Longhaul | varchar | 1 | Yes |  |
 | Fare | money |  | Yes |  |
 | Zone | varchar | 6 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Tripcodes | clustered, unique, primary key located on PRIMARY | ID
U_Tripcode | nonclustered, unique located on PRIMARY | Tripcode


Table ptms..TripDistances

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | PICKUP | varchar | 50 | Yes |  |
 | PADDRESS | varchar | 50 | Yes |  |
 | PCITY | varchar | 20 | Yes |  |
 | PSTATE | varchar | 2 | Yes |  |
 | PZIPCODE | varchar | 5 | Yes |  |
 | PZEXT | varchar | 4 | Yes |  |
 | PGISX | numeric |  | Yes |  |
 | PGISY | numeric |  | Yes |  |
 | DESTINATION | varchar | 50 | Yes |  |
 | DADDRESS | varchar | 50 | Yes |  |
 | DCITY | varchar | 20 | Yes |  |
 | DSTATE | varchar | 2 | Yes |  |
 | DZIPCODE | varchar | 5 | Yes |  |
 | DZEXT | varchar | 4 | Yes |  |
 | DGISX | numeric |  | Yes |  |
 | DGISY | numeric |  | Yes |  |
 | MILES | numeric |  | Yes |  |
 | CLTID | varchar | 10 | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | PickupID | numeric |  | Yes |  |
 | PickupSource | varchar | 1 | Yes |  |
 | DestinationID | numeric |  | Yes |  |
 | DestinationSource | varchar | 1 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_TripDistances | clustered, unique, primary key located on PRIMARY | ID


Table ptms..TripTransactions

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | TransactionNumber | numeric |  | Yes |  |
 | Vehicle | varchar | 4 | Yes |  |
 | Tripdate | datetime |  | Yes |  |
 | JDATE | numeric |  | Yes |  |
 | Date | varchar | 4 | Yes |  |
 | ClientID | varchar | 10 | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | Agency | varchar | 3 | Yes |  |
 | Funding | varchar | 3 | Yes |  |
 | Purpose | varchar | 3 | Yes |  |
 | DriverInstructions | varchar | 100 | Yes |  |
 | ProcedureModifier | varchar | 2 | Yes |  |
 | PickupTime | varchar | 5 | Yes |  |
 | ActualPickupTime | varchar | 5 | Yes |  |
 | PickupLocation | varchar | 50 | Yes |  |
 | DropTime | varchar | 5 | Yes |  |
 | ActualDropTime | varchar | 5 | Yes |  |
 | Destination | varchar | 50 | Yes |  |
 | Tripcode | varchar | 3 | Yes |  |
 | Fare | money |  | Yes |  |
 | TakeOrReturn | varchar | 1 | Yes |  |
 | Status | varchar | 1 | Yes |  |
 | Miles | numeric |  | Yes |  |
 | Rate0 | money |  | Yes |  |
 | Special | varchar | 3 | Yes |  |
 | DemandOrRoutine | varchar | 1 | Yes |  |
 | PickupZone | varchar | 6 | Yes |  |
 | DropZone | varchar | 6 | Yes |  |
 | Keydate | varchar | 6 | Yes |  |
 | Keytime | varchar | 5 | Yes |  |
 | WebVerified | varchar | 1 | Yes |  |
 | Verified | varchar | 1 | Yes |  |
 | InvoiceFlag | varchar | 1 | Yes |  |
 | InvoiceDate | numeric |  | Yes |  |
 | Invnum | varchar | 12 | Yes |  |
 | ReferenceNumber | varchar | 20 | Yes |  |
 | InvoiceAmount | money |  | Yes |  |
 | PaymentAmount | money |  | Yes |  |
 | ScheduleRecordNumber | numeric |  | Yes |  |
 | PaymentDate | datetime |  | Yes |  |
 | CreditAmount | money |  | Yes |  |
 | CreditDate | datetime |  | Yes |  |
 | WriteOffAmount | money |  | Yes |  |
 | WriteOffDate | datetime |  | Yes |  |
 | Balance | money |  | Yes |  |
 | SpecialStatus | varchar | 1 | Yes |  |
 | ActualVehicle | varchar | 4 | Yes |  |
 | Driver | varchar | 3 | Yes |  |
 | Provider | varchar | 4 | Yes |  |
 | OdometerOn | numeric |  | Yes |  |
 | OdometerOff | numeric |  | Yes |  |
 | DateTripRequest | datetime |  | Yes |  |
 | TimeTripRequest | varchar | 5 | Yes |  |
 | UserTripRequest | varchar | 30 | Yes |  |
 | DefaultPickupTime | varchar | 5 | Yes |  |
 | DefaultDropTime | varchar | 5 | Yes |  |
 | DispatchTime | varchar | 5 | Yes |  |
 | CalculatedMiles | numeric |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | DestinationID | numeric |  | Yes |  |
 | DestinationSource | varchar | 1 | Yes |  |
 | PickupLocationID | numeric |  | Yes |  |
 | PickupLocationSource | varchar | 1 | Yes |  |
 | ScheduleRecordID | numeric |  | Yes |  |
 | LastUpdate | datetime |  | Yes |  |
 | LastUpTime | varchar | 5 | Yes |  |
 | LastUpUser | varchar | 30 | Yes |  |
 | Note | varchar | 100 | Yes |  |
 | BillNote | varchar | 100 | Yes |  |
 | Renew | bit |  | Yes |  |
 | StatusReason | varchar | 50 | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_TripTransactions | clustered, unique, primary key located on PRIMARY | ID
U_TransactionNumberTripdate | nonclustered, unique located on PRIMARY | TransactionNumber, Tripdate


Table ptms..Users

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Password | varchar | 8 | Yes |  |
 | FirstName | varchar | 10 | Yes |  |
 | LastName | varchar | 20 | Yes |  |
 | Mi | varchar | 1 | Yes |  |
 | Department | varchar | 20 | Yes |  |
 | Phone | varchar | 13 | Yes |  |
 | Ext | varchar | 4 | Yes |  |
 | Note | varchar | 50 | Yes |  |
 | SystemProcessingOption1 | bit |  | Yes |  |
 | SystemProcessingOption2 | bit |  | Yes |  |
 | SystemProcessingOption3 | bit |  | Yes |  |
 | SchedulingPurgeTripsPurgeAll | bit |  | Yes |  |
 | SchedulingSupsendTripsSuspendAll | bit |  | Yes |  |
 | Suspnall | bit |  | Yes |  |
 | SetupFileInitialization | bit |  | Yes |  |
 | SetupParameters | bit |  | Yes |  |
 | SetupPasswords | bit |  | Yes |  |
 | SetupGeocoding | bit |  | Yes |  |
 | SetupSystemCodes | bit |  | Yes |  |
 | Setupf | bit |  | Yes |  |
 | SetupReports | bit |  | Yes |  |
 | Filler3 | varchar | 3 | Yes |  |
 | SetupAccess | bit |  | Yes |  |
 | WriteRecords | bit |  | Yes |  |
 | ReportWriter | bit |  | Yes |  |
 | ManagementReports | bit |  | Yes |  |
 | Setrptpriv | bit |  | Yes |  |
 | FileMaintenance | bit |  | Yes |  |
 | ClientRecords | bit |  | Yes |  |
 | VehicleServiceSummary | bit |  | Yes |  |
 | AccountsReceivable | bit |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Users | clustered, unique, primary key located on PRIMARY | ID
U_UserNumber | nonclustered, unique located on PRIMARY | Timestamp


Table ptms..ValidServiceAuthorizations

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Agency | varchar | 3 | Yes |  |
 | Funding | varchar | 3 | Yes |  |
 | Purpose | varchar | 3 | Yes |  |
 | Tripcode | varchar | 3 | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_ValidServiceAuthorizations | clustered, unique, primary key located on PRIMARY | ID
U_AgencyFundingPurposeTripcode | nonclustered, unique located on PRIMARY | Agency, Funding, Purpose, Tripcode


Table ptms..Vehicles

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Vehicle | varchar | 4 | Yes |  |
 | Provider | varchar | 4 | Yes |  |
 | Vendor | varchar | 30 | Yes |  |
 | Description | varchar | 30 | Yes |  |
 | TotalCapacity | numeric |  | Yes |  |
 | WcCapacity | numeric |  | Yes |  |
 | AmbCapacity | numeric |  | Yes |  |
 | nonambul | varchar | 1 | Yes |  |
 | OutOfService | varchar | 1 | Yes |  |
 | Garage | varchar | 35 | Yes |  |
 | GlobalStartTime | varchar | 5 | Yes |  |
 | GlobalEndTime | varchar | 5 | Yes |  |
 | WeeklyStartShift1 | varchar | 5 | Yes |  |
 | WeeklyEndShift1 | varchar | 5 | Yes |  |
 | WeeklyStartShift2 | varchar | 5 | Yes |  |
 | WeeklyEndShift2 | varchar | 5 | Yes |  |
 | WeeklyStartShift3 | varchar | 5 | Yes |  |
 | WeeklyEndShift3 | varchar | 5 | Yes |  |
 | WeeklyStartShift4 | varchar | 5 | Yes |  |
 | WeeklyEndShift4 | varchar | 5 | Yes |  |
 | WeeklyStartShift5 | varchar | 5 | Yes |  |
 | WeeklyEndShift5 | varchar | 5 | Yes |  |
 | WeeklyStartShift6 | varchar | 5 | Yes |  |
 | WeeklyEndShift6 | varchar | 5 | Yes |  |
 | WeeklyStartShift7 | varchar | 5 | Yes |  |
 | WeeklyEndShift7 | varchar | 5 | Yes |  |
 | WeeklyStartShift8 | varchar | 5 | Yes |  |
 | WeeklyEndShift8 | varchar | 5 | Yes |  |
 | WeeklyStartShift9 | varchar | 5 | Yes |  |
 | WeeklyEndShift9 | varchar | 5 | Yes |  |
 | InserviceMon | bit |  | Yes |  |
 | InserviceTue | bit |  | Yes |  |
 | InserviceWed | bit |  | Yes |  |
 | InserviceThu | bit |  | Yes |  |
 | InserviceFri | bit |  | Yes |  |
 | InserviceSat | bit |  | Yes |  |
 | InserviceSun | bit |  | Yes |  |
 | DailyStartShiftMon1 | varchar | 5 | Yes |  |
 | DailyEndShiftMon1 | varchar | 5 | Yes |  |
 | DailyStartShiftMon2 | varchar | 5 | Yes |  |
 | DailyEndShiftMon2 | varchar | 5 | Yes |  |
 | DailyStartShiftMon3 | varchar | 5 | Yes |  |
 | DailyEndShiftMon3 | varchar | 5 | Yes |  |
 | DailyStartShiftMon4 | varchar | 5 | Yes |  |
 | DailyEndShiftMon4 | varchar | 5 | Yes |  |
 | DailyStartShiftMon5 | varchar | 5 | Yes |  |
 | DailyEndShiftMon5 | varchar | 5 | Yes |  |
 | DailyStartShiftMon6 | varchar | 5 | Yes |  |
 | DailyEndShiftMon6 | varchar | 5 | Yes |  |
 | DailyStartShiftMon7 | varchar | 5 | Yes |  |
 | DailyEndShiftMon7 | varchar | 5 | Yes |  |
 | DailyStartShiftMon8 | varchar | 5 | Yes |  |
 | DailyEndShiftMon8 | varchar | 5 | Yes |  |
 | DailyStartShiftMon9 | varchar | 5 | Yes |  |
 | DailyEndShiftMon9 | varchar | 5 | Yes |  |
 | DailyStartShiftTue1 | varchar | 5 | Yes |  |
 | DailyEndShiftTue1 | varchar | 5 | Yes |  |
 | DailyStartShiftTue2 | varchar | 5 | Yes |  |
 | DailyEndShiftTue2 | varchar | 5 | Yes |  |
 | DailyStartShiftTue3 | varchar | 5 | Yes |  |
 | DailyEndShiftTue3 | varchar | 5 | Yes |  |
 | DailyStartShiftTue4 | varchar | 5 | Yes |  |
 | DailyEndShiftTue4 | varchar | 5 | Yes |  |
 | DailyStartShiftTue5 | varchar | 5 | Yes |  |
 | DailyEndShiftTue5 | varchar | 5 | Yes |  |
 | DailyStartShiftTue6 | varchar | 5 | Yes |  |
 | DailyEndShiftTue6 | varchar | 5 | Yes |  |
 | DailyStartShiftTue7 | varchar | 5 | Yes |  |
 | DailyEndShiftTue7 | varchar | 5 | Yes |  |
 | DailyStartShiftTue8 | varchar | 5 | Yes |  |
 | DailyEndShiftTue8 | varchar | 5 | Yes |  |
 | DailyStartShiftTue9 | varchar | 5 | Yes |  |
 | DailyEndShiftTue9 | varchar | 5 | Yes |  |
 | DailyStartShiftWed1 | varchar | 5 | Yes |  |
 | DailyEndShiftWed1 | varchar | 5 | Yes |  |
 | DailyStartShiftWed2 | varchar | 5 | Yes |  |
 | DailyEndShiftWed2 | varchar | 5 | Yes |  |
 | DailyStartShiftWed3 | varchar | 5 | Yes |  |
 | DailyEndShiftWed3 | varchar | 5 | Yes |  |
 | DailyStartShiftWed4 | varchar | 5 | Yes |  |
 | DailyEndShiftWed4 | varchar | 5 | Yes |  |
 | DailyStartShiftWed5 | varchar | 5 | Yes |  |
 | DailyEndShiftWed5 | varchar | 5 | Yes |  |
 | DailyStartShiftWed6 | varchar | 5 | Yes |  |
 | DailyEndShiftWed6 | varchar | 5 | Yes |  |
 | DailyStartShiftWed7 | varchar | 5 | Yes |  |
 | DailyEndShiftWed7 | varchar | 5 | Yes |  |
 | DailyStartShiftWed8 | varchar | 5 | Yes |  |
 | DailyEndShiftWed8 | varchar | 5 | Yes |  |
 | DailyStartShiftWed9 | varchar | 5 | Yes |  |
 | DailyEndShiftWed9 | varchar | 5 | Yes |  |
 | DailyStartShiftThu1 | varchar | 5 | Yes |  |
 | DailyEndShiftThu1 | varchar | 5 | Yes |  |
 | DailyStartShiftThu2 | varchar | 5 | Yes |  |
 | DailyEndShiftThu2 | varchar | 5 | Yes |  |
 | DailyStartShiftThu3 | varchar | 5 | Yes |  |
 | DailyEndShiftThu3 | varchar | 5 | Yes |  |
 | DailyStartShiftThu4 | varchar | 5 | Yes |  |
 | DailyEndShiftThu4 | varchar | 5 | Yes |  |
 | DailyStartShiftThu5 | varchar | 5 | Yes |  |
 | DailyEndShiftThu5 | varchar | 5 | Yes |  |
 | DailyStartShiftThu6 | varchar | 5 | Yes |  |
 | DailyEndShiftThu6 | varchar | 5 | Yes |  |
 | DailyStartShiftThu7 | varchar | 5 | Yes |  |
 | DailyEndShiftThu7 | varchar | 5 | Yes |  |
 | DailyStartShiftThu8 | varchar | 5 | Yes |  |
 | DailyEndShiftThu8 | varchar | 5 | Yes |  |
 | DailyStartShiftThu9 | varchar | 5 | Yes |  |
 | DailyEndShiftThu9 | varchar | 5 | Yes |  |
 | DailyStartShiftFri1 | varchar | 5 | Yes |  |
 | DailyEndShiftFri1 | varchar | 5 | Yes |  |
 | DailyStartShiftFri2 | varchar | 5 | Yes |  |
 | DailyEndShiftFri2 | varchar | 5 | Yes |  |
 | DailyStartShiftFri3 | varchar | 5 | Yes |  |
 | DailyEndShiftFri3 | varchar | 5 | Yes |  |
 | DailyStartShiftFri4 | varchar | 5 | Yes |  |
 | DailyEndShiftFri4 | varchar | 5 | Yes |  |
 | DailyStartShiftFri5 | varchar | 5 | Yes |  |
 | DailyEndShiftFri5 | varchar | 5 | Yes |  |
 | DailyStartShiftFri6 | varchar | 5 | Yes |  |
 | DailyEndShiftFri6 | varchar | 5 | Yes |  |
 | DailyStartShiftFri7 | varchar | 5 | Yes |  |
 | DailyEndShiftFri7 | varchar | 5 | Yes |  |
 | DailyStartShiftFri8 | varchar | 5 | Yes |  |
 | DailyEndShiftFri8 | varchar | 5 | Yes |  |
 | DailyStartShiftFri9 | varchar | 5 | Yes |  |
 | DailyEndShiftFri9 | varchar | 5 | Yes |  |
 | DailyStartShiftSat1 | varchar | 5 | Yes |  |
 | DailyEndShiftSat1 | varchar | 5 | Yes |  |
 | DailyStartShiftSat2 | varchar | 5 | Yes |  |
 | DailyEndShiftSat2 | varchar | 5 | Yes |  |
 | DailyStartShiftSat3 | varchar | 5 | Yes |  |
 | DailyEndShiftSat3 | varchar | 5 | Yes |  |
 | DailyStartShiftSat4 | varchar | 5 | Yes |  |
 | DailyEndShiftSat4 | varchar | 5 | Yes |  |
 | DailyStartShiftSat5 | varchar | 5 | Yes |  |
 | DailyEndShiftSat5 | varchar | 5 | Yes |  |
 | DailyStartShiftSat6 | varchar | 5 | Yes |  |
 | DailyEndShiftSat6 | varchar | 5 | Yes |  |
 | DailyStartShiftSat7 | varchar | 5 | Yes |  |
 | DailyEndShiftSat7 | varchar | 5 | Yes |  |
 | DailyStartShiftSat8 | varchar | 5 | Yes |  |
 | DailyEndShiftSat8 | varchar | 5 | Yes |  |
 | DailyStartShiftSat9 | varchar | 5 | Yes |  |
 | DailyEndShiftSati9 | varchar | 5 | Yes |  |
 | DailyStartShiftSun1 | varchar | 5 | Yes |  |
 | DailyEndShiftSun1 | varchar | 5 | Yes |  |
 | DailyStartShiftSun2 | varchar | 5 | Yes |  |
 | DailyEndShiftSun2 | varchar | 5 | Yes |  |
 | DailyStartShiftSun3 | varchar | 5 | Yes |  |
 | DailyEndShiftSun3 | varchar | 5 | Yes |  |
 | DailyStartShiftSun4 | varchar | 5 | Yes |  |
 | DailyEndShiftSun4 | varchar | 5 | Yes |  |
 | DailyStartShiftSun5 | varchar | 5 | Yes |  |
 | DailyEndShiftSun5 | varchar | 5 | Yes |  |
 | DailyStartShiftSun6 | varchar | 5 | Yes |  |
 | DailyEndShiftSun6 | varchar | 5 | Yes |  |
 | DailyStartShiftSun7 | varchar | 5 | Yes |  |
 | DailyEndShiftSun7 | varchar | 5 | Yes |  |
 | DailyStartShiftSun8 | varchar | 5 | Yes |  |
 | DailyEndShiftSun8 | varchar | 5 | Yes |  |
 | DailyStartShiftSun9 | varchar | 5 | Yes |  |
 | DailyEndShiftSun9 | varchar | 5 | Yes |  |
 | Fax | varchar | 13 | Yes |  |
 | Email | varchar | 40 | Yes |  |
 | VehicleIndentificationNo | varchar | 20 | Yes |  |
 | StartingEndingLocation | varchar | 50 | Yes |  |
 | SkipPostingforTripVerification | varchar | 1 | Yes |  |
 | TourNumber | varchar | 10 | Yes |  |
 | Timestamp | datetime |  | Yes |  |
 | DestinationID | numeric |  | Yes |  |
 | DestinationSource | varchar | 1 | Yes |  |
 | MonDriver | varchar | 3 | Yes |  |
 | TueDriver | varchar | 3 | Yes |  |
 | WedDriver | varchar | 3 | Yes |  |
 | ThuDriver | varchar | 3 | Yes |  |
 | FriDriver | varchar | 3 | Yes |  |
 | SatDriver | varchar | 3 | Yes |  |
 | SunDriver | varchar | 3 | Yes |  |
 | StrCapacity | numeric |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Vehicles | clustered, unique, primary key located on PRIMARY | ID
U_Vehicle | nonclustered, unique located on PRIMARY | Vehicle


Table ptms..VehicleServiceSummary

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Vehicle | varchar | 4 | Yes |  |
 | Driver | varchar | 3 | Yes |  |
 | Provider | varchar | 4 | Yes |  |
 | Vendor | varchar | 30 | Yes |  |
 | Tripdate | datetime |  | Yes |  |
 | Jdate | numeric |  | Yes |  |
 | Trips | numeric |  | Yes |  |
 | StartTime | varchar | 5 | Yes |  |
 | StopTime | varchar | 5 | Yes |  |
 | TotalHours | numeric |  | Yes |  |
 | StartMile | numeric |  | Yes |  |
 | StopMIle | numeric |  | Yes |  |
 | TotalMiles | numeric |  | Yes |  |
 | DeadHeadHours | numeric |  | Yes |  |
 | DeadHeadMiles | numeric |  | Yes |  |
 | Gallons | numeric |  | Yes |  |
 | PricePerGallon | money |  | Yes |  |
 | OilCost | money |  | Yes |  |
 | Breakdowns | numeric |  | Yes |  |
 | DownTime | numeric |  | Yes |  |
 | ActualVehicle | varchar | 3 | Yes |  |
 | WC | varchar | 1 | Yes |  |
 | Fares | numeric |  | Yes |  |
 | Tickets | numeric |  | Yes |  |
 | RecordNumber | numeric |  | Yes |  |
 | Comment | varchar | 50 | Yes |  |
 | UnPaidBreakHours | numeric |  | Yes |  |
 | Skipvss | varchar | 1 | Yes |  |
 | ServiceHours | numeric |  | Yes |  |
 | ServiceMiles | numeric |  | Yes |  |
 | AmbulatoryTrips | numeric |  | Yes |  |
 | WheelChairTrips | numeric |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_VehicleServiceSummary | clustered, unique, primary key located on PRIMARY | ID


Table ptms..ZipCodes

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | StateFIPS | numeric |  | Yes |  |
 | ZipCode | varchar | 255 | Yes |  |
 | State | varchar | 255 | Yes |  |
 | City | varchar | 255 | Yes |  |
 | County | varchar | 50 | Yes |  |
 | Population | numeric |  | Yes |  |
 | Allocation | numeric |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK__ZipCodes__300424B4 | clustered, unique, primary key located on PRIMARY | ID


Table ptms..Zones

 | Column Name | Type | Length | Nullable | Description | Relationships
Identity | ID | int identity |  | No |  |
 | Zone | varchar | 6 | Yes |  |
 | ZoneName | varchar | 25 | Yes |  |
 | Zipcode | varchar | 5 | Yes |  |
 | City | varchar | 25 | Yes |  |
 | UserReference1 | varchar | 25 | Yes |  |
 | UserReference2 | varchar | 25 | Yes |  |
 | UserReference3 | varchar | 25 | Yes |  |
 | Ycoordinate | numeric |  | Yes |  |
 | Xcoordinate | numeric |  | Yes |  |
 | PeakTravelMinutes | numeric |  | Yes |  |
 | NonPeakTravelMinutes | numeric |  | Yes |  |
 | Area | varchar | 4 | Yes |  |
 | Zones | numeric |  | Yes |  |
 | Match | numeric |  | Yes |  |
 | Usewin | numeric |  | Yes |  |
 | ppminut | numeric |  | Yes |  |
 | pmminut | numeric |  | Yes |  |
 | dmminut | numeric |  | Yes |  |
 | dpminut | numeric |  | Yes |  |
 | Timestamp | datetime |  | Yes |  |

Indexes on this table

Index Name | Index Description | Index Keys
PK_Zones | clustered, unique, primary key located on PRIMARY | ID
U_Zone | nonclustered, unique located on PRIMARY | Zone


Views in Database ptms

TripData


View ptms..TripData

 | Column Name | Type | Length | Nullable
 | Recnum | int |  | No
 | CltID | varchar | 10 | Yes
 | Vehicle | varchar | 4 | Yes
 | TakeReturn | varchar | 1 | Yes
 | Lname | varchar | 20 | Yes
 | Fname | varchar | 10 | Yes
 | WC-AMB | varchar | 3 | Yes
 | Agency | varchar | 3 | Yes
 | PTime | varchar | 5 | Yes
 | PAddress | varchar | 50 | Yes
 | PCity | varchar | 30 | Yes
 | PZone | varchar | 6 | Yes
 | PGisX | numeric |  | Yes
 | PGisY | numeric |  | Yes
 | DTime | varchar | 5 | Yes
 | DAddress | varchar | 50 | Yes
 | DCity | varchar | 30 | Yes
 | DZone | varchar | 6 | Yes
 | DGisX | numeric |  | Yes
 | DGisY | numeric |  | Yes
 | D-R | varchar | 8 | Yes
 | DVehicle | varchar | 3 | Yes
 | DPTime | varchar | 5 | Yes
 | DDTime | varchar | 5 | Yes
 | CltBoarding | numeric |  | Yes
 | Status | varchar | 1 | Yes
 | Actual Pickup Time | varchar | 5 | Yes
 | Actual DropOff Time | varchar | 5 | Yes
 | Odometer On | numeric |  | Yes
 | Odometer Off | numeric |  | Yes
 | Actual Vehicle | varchar | 4 | Yes
 | Miles | numeric |  | Yes
 | Fare | money |  | Yes
 | Tripcode | varchar | 3 | Yes
 | Paddress1 | varchar | 50 | Yes
 | Daddress1 | varchar | 50 | Yes
 | DriversInstructions | varchar | 100 | Yes
 | Trip Number | varchar | 20 | Yes
 | Pzipcode | varchar | 5 | Yes
 | Dzipcode | varchar | 5 | Yes
 | MedicaidID | varchar | 16 | Yes
 | DATE | varchar | 8 | Yes
 | DayNumber | numeric |  | Yes
 | StopDate | datetime |  | Yes
 | StartDate | datetime |  | Yes
 | CAddress | varchar | 50 | Yes
Primary Key | ID | int identity |  | No
 | TransactionNumber | numeric |  | Yes
 | Vehicle | varchar | 4 | Yes
 | Tripdate | datetime |  | Yes
 | JDATE | numeric |  | Yes
 | Date | varchar | 4 | Yes
 | ClientID | varchar | 10 | Yes
 | LastName | varchar | 20 | Yes
 | FirstName | varchar | 10 | Yes
 | Agency | varchar | 3 | Yes
 | Funding | varchar | 3 | Yes
 | Purpose | varchar | 3 | Yes
 | DriverInstructions | varchar | 100 | Yes
 | ProcedureModifier | varchar | 2 | Yes
 | PickupTime | varchar | 5 | Yes
 | ActualPickupTime | varchar | 5 | Yes
 | PickupLocation | varchar | 50 | Yes
 | DropTime | varchar | 5 | Yes
 | ActualDropTime | varchar | 5 | Yes
 | Destination | varchar | 50 | Yes
 | Tripcode | varchar | 3 | Yes
 | Fare | money |  | Yes
 | TakeOrReturn | varchar | 1 | Yes
 | Status | varchar | 1 | Yes
 | Miles | numeric |  | Yes
 | Rate0 | money |  | Yes
 | Special | varchar | 3 | Yes
 | DemandOrRoutine | varchar | 1 | Yes
 | PickupZone | varchar | 6 | Yes
 | DropZone | varchar | 6 | Yes
 | Keydate | varchar | 6 | Yes
 | Keytime | varchar | 5 | Yes
 | WebVerified | varchar | 1 | Yes
 | Verified | varchar | 1 | Yes
 | InvoiceFlag | varchar | 1 | Yes
 | InvoiceDate | numeric |  | Yes
 | Invnum | varchar | 12 | Yes
 | ReferenceNumber | varchar | 20 | Yes
 | InvoiceAmount | money |  | Yes
 | PaymentAmount | money |  | Yes
 | ScheduleRecordNumber | numeric |  | Yes
 | PaymentDate | datetime |  | Yes
 | CreditAmount | money |  | Yes
 | CreditDate | datetime |  | Yes
 | WriteOffAmount | money |  | Yes
 | WriteOffDate | datetime |  | Yes
 | Balance | money |  | Yes
 | SpecialStatus | varchar | 1 | Yes
 | ActualVehicle | varchar | 4 | Yes
 | Driver | varchar | 3 | Yes
 | Provider | varchar | 4 | Yes
 | OdometerOn | numeric |  | Yes
 | OdometerOff | numeric |  | Yes
 | DateTripRequest | datetime |  | Yes
 | TimeTripRequest | varchar | 5 | Yes
 | UserTripRequest | varchar | 30 | Yes
 | DefaultPickupTime | varchar | 5 | Yes
 | DefaultDropTime | varchar | 5 | Yes
 | DispatchTime | varchar | 5 | Yes
 | CalculatedMiles | numeric |  | Yes
 | Timestamp | datetime |  | Yes
 | DestinationID | numeric |  | Yes
 | DestinationSource | varchar | 1 | Yes
 | PickupLocationID | numeric |  | Yes
 | PickupLocationSource | varchar | 1 | Yes
 | ScheduleRecordID | numeric |  | Yes
 | LastUpdate | datetime |  | Yes
 | LastUpTime | varchar | 5 | Yes
 | LastUpUser | varchar | 30 | Yes
 | Note | varchar | 100 | Yes
 | BillNote | varchar | 100 | Yes
 | Renew | bit |  | Yes
Primary Key | ID | int identity |  | No
 | TransactionNumber | numeric |  | Yes
 | Vehicle | varchar | 4 | Yes
 | Tripdate | datetime |  | Yes
 | JDATE | numeric |  | Yes
 | Date | varchar | 4 | Yes
 | ClientID | varchar | 10 | Yes
 | LastName | varchar | 20 | Yes
 | FirstName | varchar | 10 | Yes
 | Agency | varchar | 3 | Yes
 | Funding | varchar | 3 | Yes
 | Purpose | varchar | 3 | Yes
 | DriverInstructions | varchar | 100 | Yes
 | ProcedureModifier | varchar | 2 | Yes
 | PickupTime | varchar | 5 | Yes
 | ActualPickupTime | varchar | 5 | Yes
 | PickupLocation | varchar | 50 | Yes
 | DropTime | varchar | 5 | Yes
 | ActualDropTime | varchar | 5 | Yes
 | Destination | varchar | 50 | Yes
 | Tripcode | varchar | 3 | Yes
 | Fare | money |  | Yes
 | TakeOrReturn | varchar | 1 | Yes
 | Status | varchar | 1 | Yes
 | Miles | numeric |  | Yes
 | Rate0 | money |  | Yes
 | Special | varchar | 3 | Yes
 | DemandOrRoutine | varchar | 1 | Yes
 | PickupZone | varchar | 6 | Yes
 | DropZone | varchar | 6 | Yes
 | Keydate | varchar | 6 | Yes
 | Keytime | varchar | 5 | Yes
 | WebVerified | varchar | 1 | Yes
 | Verified | varchar | 1 | Yes
 | InvoiceFlag | varchar | 1 | Yes
 | InvoiceDate | numeric |  | Yes
 | Invnum | varchar | 12 | Yes
 | ReferenceNumber | varchar | 20 | Yes
 | InvoiceAmount | money |  | Yes
 | PaymentAmount | money |  | Yes
 | ScheduleRecordNumber | numeric |  | Yes
 | PaymentDate | datetime |  | Yes
 | CreditAmount | money |  | Yes
 | CreditDate | datetime |  | Yes
 | WriteOffAmount | money |  | Yes
 | WriteOffDate | datetime |  | Yes
 | Balance | money |  | Yes
 | SpecialStatus | varchar | 1 | Yes
 | ActualVehicle | varchar | 4 | Yes
 | Driver | varchar | 3 | Yes
 | Provider | varchar | 4 | Yes
 | OdometerOn | numeric |  | Yes
 | OdometerOff | numeric |  | Yes
 | DateTripRequest | datetime |  | Yes
 | TimeTripRequest | varchar | 5 | Yes
 | UserTripRequest | varchar | 30 | Yes
 | DefaultPickupTime | varchar | 5 | Yes
 | DefaultDropTime | varchar | 5 | Yes
 | DispatchTime | varchar | 5 | Yes
 | CalculatedMiles | numeric |  | Yes
 | Timestamp | datetime |  | Yes
 | DestinationID | numeric |  | Yes
 | DestinationSource | varchar | 1 | Yes
 | PickupLocationID | numeric |  | Yes
 | PickupLocationSource | varchar | 1 | Yes
 | ScheduleRecordID | numeric |  | Yes
 | LastUpdate | datetime |  | Yes
 | LastUpTime | varchar | 5 | Yes
 | LastUpUser | varchar | 30 | Yes
 | Note | varchar | 100 | Yes
 | BillNote | varchar | 100 | Yes
 | Renew | bit |  | Yes
Primary Key | ID | int identity |  | No
 | TransactionNumber | numeric |  | Yes
 | Vehicle | varchar | 4 | Yes
 | Tripdate | datetime |  | Yes
 | JDATE | numeric |  | Yes
 | Date | varchar | 4 | Yes
 | ClientID | varchar | 10 | Yes
 | LastName | varchar | 20 | Yes
 | FirstName | varchar | 10 | Yes
 | Agency | varchar | 3 | Yes
 | Funding | varchar | 3 | Yes
 | Purpose | varchar | 3 | Yes
 | DriverInstructions | varchar | 100 | Yes
 | ProcedureModifier | varchar | 2 | Yes
 | PickupTime | varchar | 5 | Yes
 | ActualPickupTime | varchar | 5 | Yes
 | PickupLocation | varchar | 50 | Yes
 | DropTime | varchar | 5 | Yes
 | ActualDropTime | varchar | 5 | Yes
 | Destination | varchar | 50 | Yes
 | Tripcode | varchar | 3 | Yes
 | Fare | money |  | Yes
 | TakeOrReturn | varchar | 1 | Yes
 | Status | varchar | 1 | Yes
 | Miles | numeric |  | Yes
 | Rate0 | money |  | Yes
 | Special | varchar | 3 | Yes
 | DemandOrRoutine | varchar | 1 | Yes
 | PickupZone | varchar | 6 | Yes
 | DropZone | varchar | 6 | Yes
 | Keydate | varchar | 6 | Yes
 | Keytime | varchar | 5 | Yes
 | WebVerified | varchar | 1 | Yes
 | Verified | varchar | 1 | Yes
 | InvoiceFlag | varchar | 1 | Yes
 | InvoiceDate | numeric |  | Yes
 | Invnum | varchar | 12 | Yes
 | ReferenceNumber | varchar | 20 | Yes
 | InvoiceAmount | money |  | Yes
 | PaymentAmount | money |  | Yes
 | ScheduleRecordNumber | numeric |  | Yes
 | PaymentDate | datetime |  | Yes
 | CreditAmount | money |  | Yes
 | CreditDate | datetime |  | Yes
 | WriteOffAmount | money |  | Yes
 | WriteOffDate | datetime |  | Yes
 | Balance | money |  | Yes
 | SpecialStatus | varchar | 1 | Yes
 | ActualVehicle | varchar | 4 | Yes
 | Driver | varchar | 3 | Yes
 | Provider | varchar | 4 | Yes
 | OdometerOn | numeric |  | Yes
 | OdometerOff | numeric |  | Yes
 | DateTripRequest | datetime |  | Yes
 | TimeTripRequest | varchar | 5 | Yes
 | UserTripRequest | varchar | 30 | Yes
 | DefaultPickupTime | varchar | 5 | Yes
 | DefaultDropTime | varchar | 5 | Yes
 | DispatchTime | varchar | 5 | Yes
 | CalculatedMiles | numeric |  | Yes
 | Timestamp | datetime |  | Yes
 | DestinationID | numeric |  | Yes
 | DestinationSource | varchar | 1 | Yes
 | PickupLocationID | numeric |  | Yes
 | PickupLocationSource | varchar | 1 | Yes
 | ScheduleRecordID | numeric |  | Yes
 | LastUpdate | datetime |  | Yes
 | LastUpTime | varchar | 5 | Yes
 | LastUpUser | varchar | 30 | Yes
 | Note | varchar | 100 | Yes
 | BillNote | varchar | 100 | Yes
 | Renew | bit |  | Yes
 | StatusReason | varchar | 50 | Yes

View SQL

CREATE VIEW [dbo].[TripData]
AS

SELECT s.ID AS Recnum, s.ClientID AS CltID, s.Vehicle, s.TakeOrReturn AS TakeReturn, s.LastName AS Lname, s.FirstName AS Fname, s.Special AS [WC-AMB],
s.Agency, s.PickupTime AS PTime, s.PickupLocation AS PAddress, c.CITY AS PCity, c.ZONCODE AS PZone, c.GISX AS PGisX, c.GISY AS PGisY,
s.DropTime AS DTime, s.Destination AS DAddress, d.City AS DCity, d.Zone AS DZone, d.Gisx AS DGisX, d.Gisy AS DGisY, s.DATE AS [D-R],
s.DefaultVehicle AS DVehicle, s.DefaultPickupTime AS DPTime, s.DefaultDropTime AS DDTime, c.DWELL AS CltBoarding, s.Status,
s.ActualPickupTime AS [Actual Pickup Time], s.ActualDropTime AS [Actual DropOff Time], s.OdometerOn AS [Odometer On],
s.OdometerOff AS [Odometer Off], s.Vehicle AS [Actual Vehicle], s.Miles, s.Fare, s.Tripcode, s.paddress1 AS Paddress1, s.daddress1 AS Daddress1,
s.DriverInstructions AS DriversInstructions, s.ReferenceNumber AS [Trip Number], c.ZIPCODE AS Pzipcode, d.Zipcode AS Dzipcode,
c.MEDID AS MedicaidID, s.DATE, s.DayNumber, s.StopDate, s.StartDate, c.ADDRESS1 AS CAddress
FROM dbo.Schedule AS s LEFT OUTER JOIN
dbo.Clients AS c ON s.ClientID = c.ClientID INNER JOIN
dbo.Vehicles AS v ON s.Vehicle = v.Vehicle INNER JOIN
dbo.Destinations AS d ON s.Destination = d.Destination
WHERE (c.PICKUPPL = s.PickupLocation)
UNION
SELECT s.ID AS Recnum, s.ClientID AS CltID, s.Vehicle, s.TakeOrReturn AS TakeReturn, s.LastName AS Lname, s.FirstName AS Fname, s.Special AS [WC-AMB],
s.Agency, s.PickupTime AS PTime, s.PickupLocation AS PAddress, d.City AS PCity, d.Zone AS PZone, d.Gisx AS PGisX, d.Gisy AS PGisY,
s.DropTime AS DTime, s.Destination AS DAddress, c.CITY AS DCity, c.ZONCODE AS DZone, c.GISX AS DGisX, c.GISY AS DGisY, s.DATE AS [D-R],
s.DefaultVehicle AS DVehicle, s.DefaultPickupTime AS DPTime, s.DefaultDropTime AS DDTime, c.DWELL AS CltBoarding, s.Status,
s.ActualPickupTime AS [Actual Pickup Time], s.ActualDropTime AS [Actual DropOff Time], s.OdometerOn AS [Odometer On],
s.OdometerOff AS [Odometer Off], s.Vehicle AS [Actual Vehicle], s.Miles, s.Fare, s.Tripcode, s.paddress1 AS Paddress1, s.daddress1 AS Daddress1,
s.DriverInstructions AS DriversInstructions, s.ReferenceNumber AS [Trip Number], c.ZIPCODE AS Dzipcode, d.Zipcode AS Pzipcode,
c.MEDID AS MedicaidID, s.DATE, s.DayNumber, s.StopDate, s.StartDate, c.ADDRESS1 AS CAddress
FROM dbo.Schedule AS s LEFT OUTER JOIN
dbo.Clients AS c ON s.ClientID = c.ClientID INNER JOIN
dbo.Vehicles AS v ON s.Vehicle = v.Vehicle INNER JOIN
dbo.Destinations AS d ON s.PickupLocation = d.Destination
WHERE (c.PICKUPPL = s.Destination)
UNION
SELECT s.ID AS Recnum, s.ClientID AS CltID, s.Vehicle, s.TakeOrReturn AS TakeReturn, s.LastName AS Lname, s.FirstName AS Fname, s.Special AS [WC-AMB],
s.Agency, s.PickupTime AS PTime, s.PickupLocation AS PAddress, d1.City AS PCity, d1.Zone AS PZone, d1.Gisx AS PGisX, d1.Gisy AS PGisY,
s.DropTime AS DTime, s.Destination AS DAddress, d2.City AS DCity, d2.Zone AS DZone, d2.Gisx AS DGisX, d2.Gisy AS DGisY, s.DATE AS [D-R],
s.DefaultVehicle AS DVehicle, s.DefaultPickupTime AS DPTime, s.DefaultDropTime AS DDTime, c.DWELL AS CltBoarding, s.Status,
s.ActualPickupTime AS [Actual Pickup Time], s.ActualDropTime AS [Actual DropOff Time], s.OdometerOn AS [Odometer On],
s.OdometerOff AS [Odometer Off], s.Vehicle AS [Actual Vehicle], s.Miles, s.Fare, s.Tripcode, s.paddress1 AS Paddress1, s.daddress1 AS Daddress1,
s.DriverInstructions AS DriversInstructions, s.ReferenceNumber AS [Trip Number], d1.Zipcode AS Pzipcode, d2.Zipcode AS Dzipcode,
c.MEDID AS MedicaidID, s.DATE, s.DayNumber, s.StopDate, s.StartDate, c.ADDRESS1 AS CAddress
FROM dbo.Schedule AS s LEFT OUTER JOIN
dbo.Clients AS c ON s.ClientID = c.ClientID INNER JOIN
dbo.Vehicles AS v ON s.Vehicle = v.Vehicle INNER JOIN
dbo.Destinations AS d1 ON s.PickupLocation = d1.Destination INNER JOIN
dbo.Destinations AS d2 ON s.Destination = d2.Destination
WHERE (NOT (c.PICKUPPL = s.Destination)) AND (NOT (c.PICKUPPL = s.PickupLocation))

Copy and Paste Version of View SQL:


Indexes in Database ptms

PK_Agencies
U_Agency
PK_AgencyRateMappings
U_AgencyFundingPurposeTripcode
PK_Clients
PK_CustomReports
U_Report
PK_Destinations
U_Destination
PK_Disabilities
U_Disability
PK_Drivers
U_Driver
PK_GISParameters
PK_MiscellaneousCodes
PK__MiscellaneousCod__2C3393D0
PK_NYCmn
PK_NYParates
U_Tripcode
PK_NYPriorApprovals
U_MedidConfirmno
PK_PaSharedRideCodes
U_AgencyFundingPurposeTripcode
PK__ProcedureMatchin__756D6ECB
PK_Providers
U_Provider
PK__ReportOptions__33D4B598
PK_RevenueCodes
U_CodetypeCode
PK_Schedule
PK_ScheduledTripSuspensions
U_ClientIDScheduleRecordNumber
PK_SchedulingCapacityPerHour
U_ScheduleHour
PK_ServiceRequests
PK__States__2E1BDC42
PK__SysProcLog__31EC6D26
PK_SystemParameters
PK_Tripcodes
U_Tripcode
PK_TripDistances
PK_TripTransactions
U_TransactionNumberTripdate
PK_Users
U_UserNumber
PK_ValidServiceAuthorizations
U_AgencyFundingPurposeTripcode
PK_Vehicles
U_Vehicle
PK_VehicleServiceSummary
PK__ZipCodes__300424B4
PK_Zones
U_Zone


Index ptms..PK_Agencies

On Table | Index Description | Index Keys
Agencies | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Agency

On Table | Index Description | Index Keys
Agencies | nonclustered, unique located on PRIMARY | Agency


Index ptms..PK_AgencyRateMappings

On Table | Index Description | Index Keys
AgencyRateMappings | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_AgencyFundingPurposeTripcode

On Table | Index Description | Index Keys
AgencyRateMappings | nonclustered, unique located on PRIMARY | Agency, Funding, Purpose, Tripcode


Index ptms..PK_Clients

On Table | Index Description | Index Keys
Clients | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_CustomReports

On Table | Index Description | Index Keys
CustomReports | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Report

On Table | Index Description | Index Keys
CustomReports | nonclustered, unique located on PRIMARY | Report


Index ptms..PK_Destinations

On Table | Index Description | Index Keys
Destinations | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Destination

On Table | Index Description | Index Keys
Destinations | nonclustered, unique located on PRIMARY | Destination


Index ptms..PK_Disabilities

On Table | Index Description | Index Keys
Disabilities | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Disability

On Table | Index Description | Index Keys
Disabilities | nonclustered, unique located on PRIMARY | Disability


Index ptms..PK_Drivers

On Table | Index Description | Index Keys
Drivers | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Driver

On Table | Index Description | Index Keys
Drivers | nonclustered, unique located on PRIMARY | Driver


Index ptms..PK_GISParameters

On Table | Index Description | Index Keys
GISParameters | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_MiscellaneousCodes

On Table | Index Description | Index Keys
MiscellaneousCodes | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK__MiscellaneousCod__2C3393D0

On Table | Index Description | Index Keys
MiscellaneousCodesValues | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_NYCmn

On Table | Index Description | Index Keys
NYCmn | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_NYParates

On Table | Index Description | Index Keys
NYParates | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Tripcode

On Table | Index Description | Index Keys
NYParates | nonclustered, unique located on PRIMARY | Tripcode


Index ptms..PK_NYPriorApprovals

On Table | Index Description | Index Keys
NYPriorApprovals | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_MedidConfirmno

On Table | Index Description | Index Keys
NYPriorApprovals | nonclustered, unique located on PRIMARY | Medid, Confirmno


Index ptms..PK_PaSharedRideCodes

On Table | Index Description | Index Keys
PaSharedRideCodes | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_AgencyFundingPurposeTripcode

On Table | Index Description | Index Keys
PaSharedRideCodes | nonclustered, unique located on PRIMARY | Agency, Funding, Purpose, Tripcode


Index ptms..PK__ProcedureMatchin__756D6ECB

On Table | Index Description | Index Keys
ProcedureMatching | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_Providers

On Table | Index Description | Index Keys
Providers | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Provider

On Table | Index Description | Index Keys
Providers | nonclustered, unique located on PRIMARY | Provider


Index ptms..PK__ReportOptions__33D4B598

On Table | Index Description | Index Keys
ReportOptions | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_RevenueCodes

On Table | Index Description | Index Keys
RevenueCodes | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_CodetypeCode

On Table | Index Description | Index Keys
RevenueCodes | nonclustered, unique located on PRIMARY | Codetype, Code


Index ptms..PK_Schedule

On Table | Index Description | Index Keys
Schedule | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_ScheduledTripSuspensions

On Table | Index Description | Index Keys
ScheduledTripSuspensions | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_ClientIDScheduleRecordNumber

On Table | Index Description | Index Keys
ScheduledTripSuspensions | nonclustered, unique located on PRIMARY | ClientID, ScheduleRecordNumber


Index ptms..PK_SchedulingCapacityPerHour

On Table | Index Description | Index Keys
SchedulingCapacityPerHour | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_ScheduleHour

On Table | Index Description | Index Keys
SchedulingCapacityPerHour | nonclustered, unique located on PRIMARY | ScheduleHour


Index ptms..PK_ServiceRequests

On Table | Index Description | Index Keys
ServiceRequests | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK__States__2E1BDC42

On Table | Index Description | Index Keys
States | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK__SysProcLog__31EC6D26

On Table | Index Description | Index Keys
SysProcLog | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_SystemParameters

On Table | Index Description | Index Keys
SystemParameters | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_Tripcodes

On Table | Index Description | Index Keys
Tripcodes | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Tripcode

On Table | Index Description | Index Keys
Tripcodes | nonclustered, unique located on PRIMARY | Tripcode


Index ptms..PK_TripDistances

On Table | Index Description | Index Keys
TripDistances | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_TripTransactions

On Table | Index Description | Index Keys
TripTransactions | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_TransactionNumberTripdate

On Table | Index Description | Index Keys
TripTransactions | nonclustered, unique located on PRIMARY | TransactionNumber, Tripdate


Index ptms..PK_Users

On Table | Index Description | Index Keys
Users | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_UserNumber

On Table | Index Description | Index Keys
Users | nonclustered, unique located on PRIMARY | Timestamp


Index ptms..PK_ValidServiceAuthorizations

On Table | Index Description | Index Keys
ValidServiceAuthorizations | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_AgencyFundingPurposeTripcode

On Table | Index Description | Index Keys
ValidServiceAuthorizations | nonclustered, unique located on PRIMARY | Agency, Funding, Purpose, Tripcode


Index ptms..PK_Vehicles

On Table | Index Description | Index Keys
Vehicles | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Vehicle

On Table | Index Description | Index Keys
Vehicles | nonclustered, unique located on PRIMARY | Vehicle


Index ptms..PK_VehicleServiceSummary

On Table | Index Description | Index Keys
VehicleServiceSummary | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK__ZipCodes__300424B4

On Table | Index Description | Index Keys
ZipCodes | clustered, unique, primary key located on PRIMARY | ID


Index ptms..PK_Zones

On Table | Index Description | Index Keys
Zones | clustered, unique, primary key located on PRIMARY | ID


Index ptms..U_Zone

On Table | Index Description | Index Keys
Zones | nonclustered, unique located on PRIMARY | Zone


Databases

ABSServer\ABS
ptms
Tables
Views
Stored Procedures
Functions
Triggers
Indexes
Full-Text Catalogs

DTS Packages
Jobs

Reports

HTML Report
HTML Help Report
RTF (Word compatible) Report
Text Reports:
ptms

Documentation generated by the SQL Documentation Tool


DATABASE PTMS

TABLES

Agencies
AgencyRateMappings
Clients
CustomReports
Destinations
Disabilities
Drivers
GISParameters
MiscellaneousCodes
MiscellaneousCodesValues
NewPas
NYCmn
NYParates
NYPriorApprovals
PaSharedRideCodes
ProcedureMatching
Providers
ReportOptions
RevenueCodes
Schedule
ScheduledTripSuspensions
SchedulingCapacityPerHour
ServiceRequests
States
SysProcLog
SystemParameters
Tripcodes
TripDistances
TripTransactions
Users
ValidServiceAuthorizations
Vehicles
VehicleServiceSummary
ZipCodes
Zones

VIEWS

TripData

STORED PROCEDURES

No stored procedures were found.

FUNCTIONS

No functions were found.

TRIGGERS

No triggers were found.

INDEXES

PK_Agencies
U_Agency
PK_AgencyRateMappings
U_AgencyFundingPurposeTripcode
PK_Clients
PK_CustomReports
U_Report
PK_Destinations
U_Destination
PK_Disabilities
U_Disability
PK_Drivers
U_Driver
PK_GISParameters
PK_MiscellaneousCodes
PK__MiscellaneousCod__2C3393D0
PK_NYCmn
PK_NYParates
U_Tripcode
PK_NYPriorApprovals
U_MedidConfirmno
PK_PaSharedRideCodes
U_AgencyFundingPurposeTripcode
PK__ProcedureMatchin__756D6ECB
PK_Providers
U_Provider
PK__ReportOptions__33D4B598
PK_RevenueCodes
U_CodetypeCode
PK_Schedule
PK_ScheduledTripSuspensions
U_ClientIDScheduleRecordNumber
PK_SchedulingCapacityPerHour
U_ScheduleHour
PK_ServiceRequests
PK__States__2E1BDC42
PK__SysProcLog__31EC6D26
PK_SystemParameters
PK_Tripcodes
U_Tripcode
PK_TripDistances
PK_TripTransactions
U_TransactionNumberTripdate
PK_Users
U_UserNumber
PK_ValidServiceAuthorizations
U_AgencyFundingPurposeTripcode
PK_Vehicles
U_Vehicle
PK_VehicleServiceSummary
PK__ZipCodes__300424B4
PK_Zones
U_Zone

FULL-TEXT CATALOGS

No full-text catalogs were found.